Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox MS3250C121 - No Sound!

Posted by jtjackpot (My Page) on
Tue, Nov 16, 10 at 23:54

When turning on my 32" Magnavox, I get a picture but no sound. I also notice that the channel randomly changes on the TV from Ch 2 to 99 or Ch 99 to 2 and when doing so it also displays Mono. I am able to route Red/White sound cables to my Tuner to get TV sound out stereo speakers but I am not able to do this for DVD or Video Games.

I've gone into the TV menu and tried changing sound setting but that didn't do anyhthing. Any ideas?


Follow-Up Postings:

 o
RE: Magnavox MS3250C121 - No Sound!

Could it be a malfunctioning remote control?
The channel changing does not seem to be related to the sound problem.
Are you connecting your stereo system to the AUDIO OUT connections on the TV or is there a cable or satellite box involved?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here