Return to the Electronics Forum | Post a Follow-Up

 o
philips 32PW9525/05L

Posted by luckybo (My Page) on
Thu, Nov 16, 06 at 20:00

hi i'm having a very annoying problem with my philips 32'' widescreen tv, when i turn it on its fine works ok sound & vision both ok, then after 8-10 seconds the screen goes bright green and yellow lines go across tv then cuts out. If i turn it back on this problem still persists and as u can imagine we don't watch much tv!!
if anyone can help i'd be very greatful


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here