Return to the Electronics Forum | Post a Follow-Up

 o
Phillips Magnavox Problem Model: 20MT1331/17

Posted by ice_cat0130 (My Page) on
Tue, Nov 6, 07 at 13:50

Model: 20MT1331/17. My problem is that my tv was working fine and then I went to turn it on one day and all I got was a black screen with a single bright flickering white line going down the middle. The TV would then shut off after about 5 seconds...What could have caused this? Is this fixable? If so what can I do?

THANKS!


Follow-Up Postings:

 o
RE: Phillips Magnavox Problem Model: 20MT1331/17

I just did a Google search for this domain; http://ths.gardenweb.com/forums/electronics/
and Magnavox
and got a 97 ghits.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here