Return to the Electronics Forum | Post a Follow-Up

 o
DVD Player

Posted by clamp (My Page) on
Sat, Nov 15, 08 at 0:18

I have DVD Player Magnavox MWD200GA.Plays like a broken record. Put differant disc,same thing. They are clean. Maybe something has to be reset? This unit has only three disc run thru it,then set for 5 months when this occured.
Thank you for your time and answer


Follow-Up Postings:

 o
RE: DVD Player

Might be dust/dirt on the laser. If that doesn't do it then the laser is dieing.

Here is a link that might be useful: Here is a video on how to clean the laser


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here