Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox RS2749 C403 27'

Posted by ropefellow (My Page) on
Sun, Oct 8, 06 at 22:52

Chassis # 27Z103-00AA Manufactored in March 1994.
When I turn the TV on it comes up normal for a few seconds. The STR light comes on and the picture goes to a wide format that displays the channel numbers about 90% off the left side of the screen. I dont remember ever seeing the STR light on before. The picture and sound are otherwise perfect. I have looked in the menu and found nothing that seems to help.

Any help or suggestion would be welcomed!!


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here