Return to the Electronics Forum | Post a Follow-Up

 o
alarm system goes off after being armed for 12 days consecutively

Posted by w0lley32 (My Page) on
Mon, Oct 17, 11 at 20:58

Hi! I have a DSC PC1500 alarm system that every time I get away from home for vacation in August, gives a false alarm on zone 4 (2 motion detectors) on the 11th or 12th day. Always zone 4, for the past three years. Never had a false alarm except these three.

I have changed the two sensors, but I probably won't know if it solved the problem until next year. I could also swap zone 4 with another zone on the controller board and see if the problem follows, but I would like to know if there are any other possibilities.

I have already ruled out the power to the control panel being accidentally shut off, I have electric baseboard heat (which doesn't run in the summer), I don't have any pets (allergic to them) and I close the blinds before I leave. To my knowledge, there's nothing in the house that could be normally triggering the sensors.

I don't know if it matters, but the cable run between the control panel and the sensors on zone 4 is about 50 feet long (24 AWG 4-color "telephone" wire). I am almost positive that I don't have any rodents, but I still inspected the wires where I can see them and they are not frayed or knicked, and to my knowledge, they don't run near power cables. Nothing on the system is "wireless". Could it be that the wires are too long and/or too thin, causing a slight voltage drop that slowly increases until the 11th day where the voltage can no longer power the motion detectors?

I already have a similar post on the wiring forum, and got some good info there, but unfortunately the info I got is what I had already thought of, so I thought maybe folks on the electronics forum could further help me. Thanks for your help.


Follow-Up Postings:

 o
RE: alarm system goes off after being armed for 12 days consecuti

Could be as simple as a counter in the SW overflowing.

11 or 12 days is just over 255, the maximum count for an 8 bit (one byte) counter.


 o
RE: alarm system goes off after being armed for 12 days consecuti

Thanks. "a counter in the SW": what would it be counting (hours?), and can it be disabled? I guess it can't be re-programmed to 10 or 16 bits?

If not, I guess I'm gonna have to send someone over after the 9th day and disarm and re-arm the system? Thanks for you help.


 o
RE: alarm system goes off after being armed for 12 days consecuti

The only way your are going to be able to solve this, other than the shotgun approach of just changing parts, is to consistently replicate the problem while you are home. It may not take 11-12 days to appear.

Can zone-4 be left on and the others zones disabled while you are home?

Have you measured the controller end of the NC contact wiring with an ohm meter, at the controller end of the wiring, and compared it to the wiring of the other sensors? (They may be a resistor in line at the sensor, so it may not be zero.)

Have you tried relocating the sensor on the wall in case there may be something behind the sensor causing the intermittent trigger?


 o
RE: alarm system goes off after being armed for 12 days consecuti

Thanks for replying. Unfortunately, zone 4 is the master bedroom and home office, so I can't leave that zone disabled while in the house. I could swap it with zone 5, but I have to go through it to do my laundry, so I can't leave it armed for 12 days consecutively.

About relocating the sensors, I know there's nothing electrical or AC lines behind them, and I guess magnets wouldn't affect them?

I had someone to whiggle the wires while I checked for continuity/short-circuitting at the control panel and everything was fine, but I will measure impedance of both zones 4 and 5 this weekend, as these two zones both have two motion detectors.

Maybe I am completely off the track, but it seems to me that "intermittent triggering" that only happens on the 12th consecutive day of being armed is probably not intermittent but rather something that is bound to happen after 12 days. I have never had any false triggering except those 4 events. I have gone on week-long trips, and never had an issue.

Brickeyee, you suggested "a counter in the SW overflowing"; I suppose you meant the software in the control panel board? I have downloaded the service manual, and I can't find any reference to a counter. What would be the purpose of such a counter?

The DSC PC1500 seems to be a popular system, because my Internet search led me to many discussions about it, and I personally know at least three persons who have or had them. Now that I think of it, my uncle is one of these persons, and him too has a false trigger every time he goes away for a long period of time, so the theory of the counter overflowing starts to make sense to me. Are we the only ones leaving our system armed for two weeks while I go on vacation?

Sorry for the long post, and thanks for helping me with my problem.


 o
RE: alarm system goes off after being armed for 12 days consecuti

At this point, I wouldn't start swapping zones right now - it may just add more confusion.

As far as relocating, the sensors can be sensitive to RF interference and, although they shouldn't be, temperature changes on the wall.

But first, if you have the installation/service manual - not the owners manual - you can see if zone-4, or all the zones, are "supervised alarm zones/circuits."

When I mentioned it may contain a resistor (end of line), it is because of supervised circuits. Supervised circuits, in simple terms, the alarm control panel is acting in a tri-state mode.

It it always looking to see a certain resistance across the circuit; let's just say 1k, it's a NC circuit, and the resistor is in series. A cut of the wiring triggers a high resistance error and sets the alarm mode. Somebody who places a jumper across the wiring, triggers a low resistance error and sets the alarm mode as well.

The resistor value that must be used will be listed in the installation manual. Since ambient temperature affects resistor values, placement on a wall heated by the sun could cause enough change on a high tolerance resistor to cause an error - but that's just in theory and there's usually enough tolerance in the system, but it could happen.

A simple test to help determine sensor, wiring, or controller fault would be to first determine if this is a supervised circuit and it's resistance value. Disconnect zone-4 wiring, at the controller, and either jumper with the appropriate resistor (or just a short wire if non-supervised) and disable all zones but 4. Let it run for a couple weeks and see what happens. Just kind of flowchart logic from there.

But actually, I also have another thought here. You mentioned zone-4 is master bedroom and home office, so I'm thinking a PC in the home office... maybe a UPS power supply? Maybe one with an "auto test feature?" I even had an APC unit that by default ran an auto test mode "about every two weeks" - now with the full cycling of the UPS, and it's temperature changes, that could possibly trigger an IR detector... just a thought.


 o
RE: alarm system goes off after being armed for 12 days consecuti

Thanks a lot for the reply. You've got a good point about the UPS, but I don't have one, and I unplug the computer and its peripherals from the wall while I go away.

While temperature variations are still a valid argument, I was gonna write that at least two false triggerings happened at around 5:00 AM, when the temperature inside and outside the house is at its lowest. Interestingly enough, 5:00 AM is also the time that I usually leave home for my trip and arm my system.

I'm gonna check the manual carefully to see what resistor value is needed, and I will install it in the panel downstairs. I know for a fact the only zone that has a resistor (1K, 1/4 watt, 10% tolerance) is zone 6, which is a fire zone, unless the detectors have them built-in.

Once again thank you, and I will keep you updated once I check if the proper resistors have been used.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here