Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox 20 inch flat screen model # 20ms3442/17 stopped working

Posted by saju (My Page) on
Sat, Sep 15, 07 at 14:15

Hi I am having a weired problem with my 20 inch Magnavox flat screen TV. The TV is only 2 years old. Till yesterday I didn't have any problem with this TV. All of a sudden it started behaving this way. The TV is automatically going through (counting) the channel when the power chord is plugged in but the standby button is not getting lit. Everytime I unplug the power chord and replug it again the TV screen displays CATV Mono. If I press and hold the TV/AV button then it plays the VHS. If I press and hold the menu button to my cable channel number then the cable works. the volume button works. But the power, channel buttons and remote control doesn't work. basically now I can't use the TV.

Please help.


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here