Return to the Electronics Forum | Post a Follow-Up

 o
Philips Maganovox 54' Big Screen Model# 9p5534 C103

Posted by bobbieharr (My Page) on
Sat, Sep 30, 06 at 9:59

For a few weeks now the picture has been going in and out. Taking its time to "warm-up" and now the tv all of the sudden would not show a picture. The screen is completely black; although the power light is on. I can use the remote to power the tv on and off. Anthing that I click from the remote allows the green power light to blink. Also there is no sound. The tv is about 5 years old. Please Help


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here