Return to the Electronics Forum | Post a Follow-Up

 o
philips tv model 50p8341 no pic no sound

Posted by panela (My Page) on
Sun, Aug 12, 07 at 20:53

ive sent one message but i guess i must have not done something right. i have a philips tv projection model 50p8351 chasis ptv915 i have no sound no picture . the power button lights up with red light. can you please help me... i really appreciate it.


Follow-Up Postings:

 o
RE: philips tv model 50p8341 no pic no sound

hi-
you might want to try asking your question again at the following site: http://www.tv-forums.com as they seem to be more active than this one wrt responding on issues regarding tv repair


 o
RE: philips tv model 50p8341 no pic no sound

there is a resistor under the main board which goes up in value its a surface mounted res very near resistor 3314 it has a no stanp on it 14r7 check it value its should be around 14 to 15 ohms.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here