Return to the Electronics Forum | Post a Follow-Up

 o
Philips Magnavox problem 32' TS3258

Posted by stallam (My Page) on
Sat, Jul 11, 09 at 13:29

I have a 32" Philips Magnavox (TS3258 C101), Chassis Model 32D700-7570, Manufactured Dec '98

I have been using this for last 10 years, and it stopped working suddenly.

When I turn on the TV (front button), nothing happens, no green LED, no sound, no picture.. As long as it is plugged into the wall, it makes very low audible tic tic tic sound (is it relay click ?).

Any suggestions on what I can do to fix it...


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here