Return to the Electronics Forum | Post a Follow-Up

 o
Philips Magnavox TS2754C107

Posted by phylu (My Page) on
Mon, Jun 18, 07 at 19:26

PLEASE HELP!
I have a tv who's vertical circuit seems to have gone out. Turned it on this morning, first a ~1" wide horizontal stripe appeared, then moments later it changed to a vertical strip from near halfway down the screen to the bottom. Sound is perfect. I'd like suggestions on how to repair, and I am no TV tech - even would like to know how to open the back of the TV.
Can't afford a repairman, don't want to lose this TV, Can you help/guide me?
Either way, thank you!
pu


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here