Return to the Electronics Forum | Post a Follow-Up

 o
7p5433-w101 chassis ptv775-aho1

Posted by shelleyb66 (My Page) on
Mon, May 7, 07 at 8:37

Oct.1997. Two out of the three lenses (blue & green) seem to be clouded with a liguid splatter pattern that is cooked on to the inside of the lens. The red one is clear. Are the lamps bad? Where do I find replacement lamps? Are there any substitutes? Is there a repair manual for this model? Online? Can I clean these lamps and maintenance them myself? Where can I find a remote for this model?

It has a ghost image/aura and a heavy red tint to the picture.

#7p5433-w101 ser#74418428 chassisptv775-aho1


Follow-Up Postings:

 o
RE: 7p5433-w101 chassis ptv775-aho1

Time to move down.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here