Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox 25TS56 C221 no picture or sound

Posted by tech3627 (My Page) on
Thu, May 17, 07 at 0:50

A little bit of water got spilled onto this TV when it was on. The picture started to change colors and then the TV turned itself off. I unplugged it overnight. In the morning it come on, but after just a couple of secounds there was a sizzling noise, then the picture started to change colors again and turned off. I opened up the cover, but did not see anything that stands out to me. Can anyone help me? Chassis #25F800 7583 Manufactured Feb 2001 Date code 1211U081B. I do have a Fluke 88 multimeter to do testing and have a more that basic understanding of electronics.
Thanks,
Lot


Follow-Up Postings:

 o
RE: Magnavox 25TS56 C221 no picture or sound

time to move down


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here