Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox Model #MS3250 C321 Chassis#32T800 7629

Posted by nygirl123 (My Page) on
Tue, Apr 12, 05 at 19:36

Just a little warning this is a long post because it's a complicated story but I summarized as best as I could while still getting all the important facts in.

I posted a little while ago about a problem with my TV turning itself off. At that time I was getting a black screen with colored lines across the middle and the TV would cut off shortly after being turned on (the power indicator light, though, would remain on). Since then some things have happened.

My television now has a grey square with white lines on the screen (it doesn't fill the entire screen)and the sound is normal. I had a "professional" do a house call to troubleshoot the problem and after testing it he said that the problem was with the IC (model #TDA6107Q/N2; part number on partstore.com= 935257650112). This part is found on the circuit board near the picture tube. The change in the picture I mentioned above occurred after he opened the back and did his troubleshooting.

Well I waited a week for the repairman to return and fix my TV and kept getting excuses about other jobs he had. I expressed my frustration to a friend and he offered to replace the part if I ordered it since he once studied electronics. He figured that even though he hadn't used the knowledge in TV repair all he was doing was replacing a part so he just needed the basics anyway. He came to look at my TV to see if he could install the part. At that time, he felt that there might also be a power problem since the TV would just turn itself off. He thought one of the electrolytic capacitors might have blown which would also explain the "popping" sound I heard before all this trouble began. He looked to see if any of the capacitors were blown and found one that might be the culprit. He then tested the capacitor with his voltage meter (or something like that; I know nothing about electronics) and found that it was not putting out the correct capacitance value stated on the side. So I ordered both the IC and the capacitor.

He replaced both and my TV is having the same problem. Absolutely no change! He also used his meter to test the resistor, R3340, which I saw was the cause of a similar problem in another post and he said that the circuit was closed. I didn't really expect the capacitor to solve the problem since my friend is, in essence, an amateur but the TV repair guy, despite his unprofessional behavior, is supposed to know his stuff! I mean the guy spent quite a bit of time testing stuff on the circuit boards. I have considered trying another repair shop to see if they can troubleshoot the problem but I really don't want to go to any additional expense if this is actually an expensive repair like a blown picture tube or something (not to mention lugging a 36 inch TV down 3 flights of stairs). I'm hoping I can get some help on here before I end up trashing a good TV that's easy to fix.

Thanks for reading and any help you can give.


Follow-Up Postings:

 o
RE: Magnavox Model #MS3250 C321 Chassis#32T800 7629

First, all 'tv repair guys' are not professional, nor do they 'know their stuff'. Just like doctors, lawyers and indian chiefs.

Unfortunatly, the one that you had didn't know 'squat'.

The ic that was replaced on the picture tube circuit board, was the crt driver, which means picture tube driver. If it is defective, you will have 'NO PICTURE - EVER'. That's no biggie.

The dark square that is showing on the screen, after the tv repair guy, checked the set, is caused by a menu adjustment. On the customer menu, 'TEXT' is turned on and should be turned off.

Your first symptom was the set turning off, with a black screen with colored lines across the screen. This symptom indicates a failure in the "vertical circuit".

A failure in the vertical circuit causes the picture to turn off. This is a safety circuit to prevent burning a line in the phosphor, thereby protecting the picture tube.

'Vertical failure' can be caused by defective solder connections on the vertical ic. This is due to the heating and cooling, ie expanding/contracting of the connections.

First, resolder the ic connections. They may appear 'good', but resolder anyway. I believe that the leads can be reached by just turning the set up on its side.

The vertical ic is located at the rear of the circuit board. A 'clip' holds the ic to the metal frame(heat sink).

If that doesn't cure the problem, you will need to replace the vertical ic. IC7471(TDA8359J).

good luck,

pw


 o
RE: Magnavox Model #MS3250 C321 Chassis#32T800 7629

Pee Wee,
I have a similar problem with my Maganavox Model MS3250C321. It's a 32" that keeps turning itself off. We try turning it back on , however it just keeps doing the same thing and turning itself off again after about 5 seconds. The power red led stays on, however no sound or picture. When this happens, it just goes black, and unlike the others mentioned here, it does not show any lines or color at all when it does this. I saw similar problems on the forum like this and tried to repair it by replacing the R3340 resister with a 10ohm, 1/2 watt, on the Crt board, however that made no difference either. Any suggestions as to what to look for? Any help would be appreciated, but please remember that I am only a novice at this, with some electronic experience only. Thanks Bill R.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here