Return to the Electronics Forum | Post a Follow-Up

 o
phillips magnavox 60p8241 nosound or image

Posted by xboxhacker (My Page) on
Fri, Apr 27, 07 at 17:08

Phillips Magnavox 60P8241:

The other day i turned on the TV and i get no sound or any raster. I looked in the back and i can see the heaters for the CRTs glowing, and i can hear high voltage scream. I repair arcade monitors for a living, so i can rework PCBs and read schematics. But i have never working on a projector before, so i am lost. My best guess is that one or more of the guns are bad. So how do i test the guns? Are they worth replacing? I see a lot on this forum about problems sound with no picture, but i dont have either :( If anyone can help that would be great!


Follow-Up Postings:

 o
RE: phillips magnavox 60p8241 nosound or image

time to move down


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here