Return to the Electronics Forum | Post a Follow-Up

 o
Phillips Magnavox 60P8241

Posted by lavastia (My Page) on
Mon, Apr 16, 07 at 0:50

My parents just bought a Magnavox 60" Model# 60P8240 from some friends. I hooked it up for them and it works fine other than the lack on any OSD's. No volume meter, no channel numbers, and I'm not able to even pull up a menu using neither the front of the TV nor the remote. The picture is slightly fuzzy and they want to adjust the settings but I've no idea where to start.

I called magnavox and they weren't too inclined to help being as it's fairly old considering and it was bought second hand. Any information would be much appreciated.


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here