Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox TV MS3252

Posted by hackerk (My Page) on
Thu, Apr 26, 07 at 0:02

I have a Magnavox MS3252S431 that is not quite four years old. It hadn't been used in 6 months until tonight. When we turn the TV on, the screen and sound come on for about 15 seconds and then the screen goes completely blank and the sound disappears. The green light on the front of the TV is still on.
Is this TV fixable?
Thanks!


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here