Return to the Electronics Forum | Post a Follow-Up

 o
Phillips TV problem

Posted by bcoker4185 (My Page) on
Wed, Mar 22, 06 at 7:17

Phillips model # 27PT543537A. Worked fine for about 1 1/2 years, then screen would go black right after turning on. If we would change the channel repeatedly, we would get a picture after about 1-2 minutes. Now we just hear a clicking noise from the interior, but no power light even. Is this worth having repaired?


Follow-Up Postings:

 o
RE: Phillips TV problem

I'm having the same problem that you had with my TV. Did you end up getting it fixed or just get a new one?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here