Return to the Electronics Forum | Post a Follow-Up

 o
Philips/Magnavox TV

Posted by auburn_guy (My Page) on
Sun, Jan 21, 07 at 22:02

Philips/Magnavox TV #25TS56CI with an imaging issue. If I connect an antenna or Cox cable to the TV's ANT/CTV input the image is scrambled - with either vertical or horizontal rolls. Sound is intermittent as well (stereo, mono or none). Also, when using Cox cable and an image does appear it is in a negative format. When I connect the Cox cable to an old VCR and use RCA connections between VCR/TV the image and sound are perfect. The downside is VCR doesn't receive all of the cable channels. Any ideas/suggestions for TV repairs? Thanks.


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here