Return to the Electronics Forum | Post a Follow-Up

 o
Magnavox 51mp392h/17

Posted by brucenh1 (My Page) on
Sat, Jan 27, 07 at 11:15

Hello,
I bought a 51" HD ready Progressive Scan (51mp392h/17) TV about 2 years ago from Circuit City. Just today, the blue gun is off causing blue shadows on the screen. If I go to the convergence menu, I can move the blue left & right, but not up & down. Additionally, the blue seems correct in the upper left quadrant of the screen. At the bottom, it seems to arch up in the middle. In the upper right quadrant, it is way off, up and to the right. The red convergence works correctly. Is this something I can troubleshoot and fix myself? I'm an old EE, now Computer IT/guy so replacing modules and/or soldering is not out of the question. Are there service manuals available on the web somewhere?

Any help/guidance/pointers would be greatly appreciated.

Thanks,
Bruce


Follow-Up Postings:

 o
RE: Magnavox 51mp392h/17

OK, so I know this is a dead thread and probally you all either fixed the TV's or thru them out, however I'm still trying to find a Convergence circuit board for my Magnavox 51MP392H/17. I'm hopeing somone still has their junk TV sitting around and is willing to sell me the boards out of the TV. there are 3 main boards in the bottom of the set, I need the one on the left its the SSB convergence circuit board # 3135-013-3263.5 I Know how to fix mine, however I can't afford to buy a new part and I can afford a repariman so if you can please help me out with a used part I'd be very grateful.
Edwinkraus@hotmail.com
PS, Please please sell me your convergence circuit board


 o
RE: Magnavox 51mp392h/17

Hi, I don't have a convergence board for sale but if you know how to solder you can repair the one you have. It's not hard. If you need help finding the parts and how to replace them, let me know. You can email me at rgotro@embarqmail.com
Frenchy


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Electronics Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here