Return to the Cookware Forum | Post a Follow-Up

 o
electric skillet heat problem

Posted by cciaffone (My Page) on
Tue, Nov 21, 06 at 9:43

We replaced our older Farberware Electric Skillet with a
newer version several years ago. Now the newer skillet
does not seem to heat as well. We have to set it about
50 degrees warmer than we did with the older pan to get
the same result. Fortunately we kept the old pan.

Is this likely a problem with the cord/probe or with the
heating element in the skillet?? (The cords are not
interchangeable so we can't try a swap.)

thanks

chuck


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cookware Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here