Return to the Computer Help Forum | Post a Follow-Up

 o
Firefox does not recognize lat Flash Player updateest

Posted by windslam (My Page) on
Mon, Jun 27, 11 at 19:37

I hope someone has an answer to this one. I have tried every suggestion on the internet.

Firefox gave me a message last week that it disabled my previous version of Flashplayer and to install the latest plugin. I clicked on the install, it took me to the Adobe site to download the latest plugin. The wizard downloaded and claims to have installed the plugin. Well, now Firefox keeps prompting me to install the latest plugin, even after I have already done so and did the reboots. I even went so far as to uninstall both, firefox and Flashplayer and reinstall them.

Using Windows XP with SP3
Firefox 5.0
Flash Player 10._______.26 This is the only update available

Any ideas?

Thanks


Follow-Up Postings:

 o
RE: Firefox does not recognize lat Flash Player updateest

Did you download the Flash dedicated to other than IE? If you install directly you must be using the target browser. If you save and then install you can use any browser for the task. The key is the proper download.

DA


 o
RE: Firefox does not recognize lat Flash Player updateest

Thanks for your response.

I was originally in firefox, it gave me the bar to download the latest plugin update. I selected the link it provided, it automatically took me to the specific download, downloaded it, with a status bar and everything. Then it supposedly installed it, again with a status bar while installing. It automatically restarted firefox and that's when the problem started. I subsequently ran the uninstall utility for firefox and also ran the specific uninstall program for Adobe Flash player. I then went to Mozilla to download firefox, clicked on the link and it installed it for me. I rebooted my computer, opened firefox, went to a site that I knew flash would be needed, firefox again gave me the bar to update flash to the latest version, I clicked the link provided by firefox, it went through all the same gyrations described above. It also restarted firefox automatically, and the bar reappeared requesting to update the plugin for flash. I went to a site, indeed, need the plug in to view. I again uninstalled firefox and then uninstalled Adobe Flash Player. I rebooted my computer, went to mozilla, downloaded and installed fire fox. While in firefox, I downloaded flash, the version for firefox, and manually ran the .exe. It informed me it would close firefox and continue the installation, which it automatically did do. after a warm boot, same problem. Did a cold boot, same problem. There is a boat load of "things to try" out there on the web and I've tried every one that seemed logical. Nothing works. I like firefox and every other plugin and service works perfectly except for flash player.

By the way, I noticed in my original post, my cursor did some jumping around...that is because my hand was probably too close to the touch pad while typing...sorry.


 o
RE: Firefox does not recognize lat Flash Player updateest

Have you used any other browser and been able to update Flash Player? Maybe this is a glitch in v.5 of Firefox.


 o
RE: Firefox does not recognize lat Flash Player updateest

On Google I did see some recent reports of concerns with FF 5.0 and the Flash update.

How about deleting the new Flash and installing the prior version? Or reverting back to FF v4.0.1? Or both?

DA

Here is a link that might be useful: Filehippo


 o
RE: Firefox does not recognize lat Flash Player updateest

I deleted Flash and installed an earlier version, didn't work. Checked out in IE and it didn't work there either. I will uninstall FF and Flashplayer tomorrow, reload older versions of both and see what happens. I do recall an earlier message from FF when all this started, that FF has disabled my older version of FlashPlayer and to click on the link and firefox would install the new version. I'll back everything out and start over...very frustrating!!!!

If this doesn't work, is there something I can use in the place of FlashPlayer that the browsers can default to?

Thanks Gang


 o
RE: Firefox does not recognize lat Flash Player updateest

the newer browser versions are being written more for windows 7 and not so much for xp anymore, just like IE9 is not to be used on xp the newer versions of firefox will be moving in the same direction, so you will see problems popping up with some things if still using xp. Not everyone will experience them depending on their systems and configurations. So just keep that in mind if you are using xp and start to see some issues. Not saying you can not try them just be aware you may see some issues.

Personally I never click on any link anywhere to install flash or anything else I go directly to the actual download site and do it right from there, you never know when there could be a clickjacking attempt, and in fact there was one in firefox some time back like that.
Try going directly to adobe flash download, look it up in google and go there and select your browser and your download and do it there, then go to the test page to make sure it has loaded. here is the flash page with the download link
Flash Player

Here is a link that might be useful: flash test page


 o
RE: Firefox does not recognize lat Flash Player updateest

I've used every removal tool available to remove all instances of Adobe from my computer. I've used registry cleaning utilities to remove any remnants of Adobe from the registry. This includes readers or anything else associated with Adobe. Using IE, I systematically loaded an older version of FF. I then opened FF, made it my default browser, went to various sites I knew Adobe reader would be called for and when it asked to load reader, I went to the Adobe site and loaded the version of reader I originally held. Reader worked fine. I went to a site requiring the Flash plugin, went to the Adobe Site and downloaded the version of Flash I originally had before the problem. When I revisited the site where Flash was needed, FF gave the message that I would have to update my version. I went to the adobe site, I noticed the latest version had changed from 10._____.26 to 10.____.34 within a few days of the problem. I manually downloaded the latest version and installed it. When returning to various sites where I had been prompted to update Adobe FF CONTINUES TO ASK ME TO UPDATE THE PLUGIN. The flash player DOES NOT work.

This all started when FF forced a tab at every boot that they had turned off my older version of the Flash Plug In and that I would have to download the latest for flash to work. The tab would show up every time I loaded FF. Searching the web I noticed many people had this complaint. I finally did as requested and the problem started. I did notice as updated plugins were loading, various boxes for other things were checked as YES by default, such as Norton, Yahoo, Chrome etc. I unchecked those additional options.

Does anyone know a switch somewhere in the bowels of software or registry on the computer that could have been changed, that needs to be reset somewhere back to it's original value? I agree, XP may not be the latest operating system but I can't imagine FF to require everyone to upgrade their operating system. I still have one laptop using Win 2000 and don't have the problem, it may be unsupported but all the latest updates were made before MS turned off the support. Some switch somewhere got changed when attempting to upgrade at FF's request.

I plan to stay on this until I get it resolved, I was just hoping someone did a little more drilling down or is computer knowledgeable enough to know the answer. From my web search, this is not a new problem. I suspect many people just switched to a different browser when FireFox started to appear unstable. Too bad, I like FF.


 o
RE: Firefox does not recognize lat Flash Player updateest

Your concern does puzzle me. I went from FF v4.0.1 to v5.0 without any concern. At the time I had Flash v26. As I saw no real advantage to v5.0 so as to outweigh the loss of numerous add-ons I deleted v5.0 and reinstalled v4.0.1. Again, no problems.

This is a stretch. Have you tried downloading from a mirror site such as Filehippo rather than from Adobe?

DA


 o
RE: Firefox does not recognize lat Flash Player updateest

DA I think it is working for you, because, you do not use XP. I had problems with 4.0.1 on my XP and deleted it. I put it on my Vista the other day, and absolutely no problems what so ever. I will wait a while on the 5.0 for the Vista too. When an operating system gets a bit older, what comes out new, is not designed for that operating system, it is designed for newer operating systems. On my old 98's the version of Firefox I am using on here, do not work on them, so I have a bit older version yet on there. So far, there are no problems accessing anything, with any of my versions on the 98's or XP. Most everything works great yet on the Vista.


 o
RE: Firefox does not recognize lat Flash Player updateest

I'm just curious... when you uninstall firefox if you removed it totally... or you had it save existing settings - which means your gonna loose all other plugins and favorites, custom settings, etc..

Hae you looked in manage at error logs for errors that might be related to flash ? Possibly you some conflict, maybe/probably with aother plug-in. Would be my first guess.

Rather than installing Flash at adobe's automatic way, I always download them then run them from the installs manually with all the browsers and instant messengers closed. Usually its pretty smart to tell you then,, something about what is open & or why it cant complete the install.


 o
RE: Firefox does not recognize lat Flash Player updateest

I am using FF v.5.0 on XP SP3 along with Flash Player 10.3.181.34 and have run into no problems at all. Now, FF is not my default browser, but I do use it for several sites, and it seems just fine.


 o
RE: Firefox does not recognize lat Flash Player updateest

Just an FYI...Today I used REVO to delete all occurances of Adobe products and removed FireFox. I then used a Registry cleaner utility from Fix-It made by Avanquest, to clean the registry of all Adobe files. Please note, when I removed FF, Ileft perasonal settings on the computer by choosing the appropriate yes box in the uninstall program. I did a cold boot. I opened IE, went to a site that needed Flash Player. I installed it through I.E. and everything works fine. I installed FF, and it is still prompting me to install plug-ins. I went back to I.E. Using now) and everything works fine.

I suspect there is a toggle somewhere in FF that got switched to either true or false that might be causing the problem. I will remove everything and all related to FF, clean the reigstry of anything related, personal settings and all. I will then do a cold boot and load FF from scratch, doing the import from I.E. things and make it my default browser.

In the mean time, do you users of Chrome like it? What is the best thing you have observed about it after using it?


 o
RE: Firefox does not recognize lat Flash Player updateest

Plug in for FireFox is not installed when you install from the web usisting internet explorer... look in the add-ins

FireFox uses a seperate plugin from IE... seperate download,, seperate install.

If you want to email me,, i'll attach and send you current flash install for firefox. Or both IE & FireFox flash and the adobe uninstaller too.


 o
RE: Firefox does not recognize lat Flash Player updateest

I use Chrome and love it. It is fast, no need for lots of add-ons, although there are some that I use. I like the minimalist appearance since I hate clutter. I have been using it as my default browser for about 2 years. I still use FF occasionally and IE only when I have to (downloads from MS). I do keep them all updated.

Yes, what Mikie said is true. The Flash for IE doesn't do the job in other browsers. The same one works in both FF and Chrome.


 o
RE: Firefox does not recognize lat Flash Player updateest

mik,

You're a good person!!! I'll see what happens when I do a clean install. The last time I visited the Adobe site to do a manual download, the version numbers on the list were all the same. You would think when FF goes out and gets the update, it would get the right one. Just to help isolate the problem, let's see what happens with the clean install before I put you through the trouble of gathering and sending the info.I see a lot of complaints on the web concerning the issue and would surely like to isolate it and pass the info. along.

Thanks for the Chrome info grandms. I have a Win 7 machine and may try it on that. This particular XP laptop is my general purpose, traveling and web visiting machine (no personal banking, business etc.).

Thank you all for trying to help!!! I lurk here often just to pick up info. and you regular folks know your stuff.


 o
RE: Firefox does not recognize lat Flash Player updateest

you most definitely must look at the flash download site and select the specific one for either firefox or Ie one will not do you have to have the 2 different ones. When you go to the flash site just look it will say for different browser and you click there to see the various options.
Install a different version of Adobe Flash Player

Flash Player 10.3.181.34 (Non-IE)


 o
RE: Firefox does not recognize lat Flash Player updateest

It looks like I got the problem resolved. I used REVO to totally remove FF and all references to it, including personal settings. I opened I.E and browsed the web and all worked well. I.E. is using the FIREFOX version of FLASH PLAYER 10______.34 which I manually installed into I.E. and it accepted.

I then ran the install for FireFox 5.0 As it was loading it asked me if I wanted to import settings from I.E., I opted YES, I was then asked if I would like to make FF my default, I opted YES. Once done and without making any changes or additional additions or actions of any kind, FF imported everything I had in I.E. I went to several sites I knew Flash Player would be needed and everything worked fine.

It appears as I suspected, there was a toggle somewhere in FireFox that got toggled to either TRUE or FALSE. I wish I could have determined which one, to have made this problem go away sooner. If time permits, I may play with them until I can recreate the problem.

Thanks much to all of you who responded and were so willing to give up your time and effort to help me.


 o
RE: Firefox does not recognize lat Flash Player updateest

Good for you. Nothing better than success from personal perseverance.

Thank you for the achievement report. You never know when something like this might come up again.

DA


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Computer Help Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here