Return to the Cleaning Tips Forum | Post a Follow-Up

 o
Shark Steam Mop-Help

Posted by firsttimebldr (My Page) on
Sun, Jun 22, 08 at 23:00

After much research I bought this mop. Did all the assembly like it said and NO water/steam will come out. I pumped a hundred times. What am I doing wrong or is it defective? Thanks for any advice or opinions. Betsy.


Follow-Up Postings:

 o
RE: Shark Steam Mop-Help

If you. .
1. put water in it
2. plugged it into a working outlet
3. let it heat up about 5 minutes
and after that with pumping you got no steam then I say the mop is defective. Debbie


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cleaning Tips Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here