Return to the Cars Forum | Post a Follow-Up

 o
Question For Dodge Experts

Posted by iggie (My Page) on
Sun, Dec 21, 08 at 19:40

A young friend has a 99 Intrepid with the 3.3 engine, ocassionally the car makes a whining noise and the transmission will not pull unles he shifts to D1 and some times even then it simply will not move engine revs up fine. he can let it sit awhile and it may run for days and be ok. One of the national transmission repair chains told him his transmission was ok problem was electrical they replaced battery and alternator car ran ok for about a week and started the same thing again. Is the tranny control module bad or what? We would apprecate any advice or suggestions


Follow-Up Postings:

 o
RE: Question For Dodge Experts

The whirring noise could come from two possible sources, the torque converter, or the front pump. It sounds like you are describing either condition which in the early stages can play "hide and go seek" with you. The front pump problem will normally start to get the transmission controller to set codes for a "loss of prime". This is also accompanied by a transmission that starts to shift harder and harder as the computer keeps compensating for the problem. This is one of the things that shows the difference between having the same scan tool that the dealer does, the DRBIII, as compared to aftermarket tools such as the OTC Genysis, or one of the Snap-On tools. Most of the time you wont find the learned compensation data with an aftermarket tool, meanwhile a dealer tech, or an independent who has made the investment way beyond the norm has access to that information which makes the diagnostics easier. With no compensation data reporting irregular, then the diagnosis is the converter is failing. However the repair would still be the same either way. Pull the transmission, replace the converter, replace the front pump assembly. Since its out and apart, it does not make any sense to not overhaul it, and then update the TCM's software to the newest calibration.

(And to think I have never read a Chilton's manual, VBG.....)


 o
RE: Question For Dodge Experts

John_G has given you the straight scoop. For what its worth, I'll give my 2 cents.

I had a '92 Dodge Dynasty with the Chrysler built 3.3 L V6, and I suspect that my engine and transmission was similar to yours.

The symptoms you mention smell like worn-out clutches to me. If this transmission is in the neighborhood of 100,000 miles, then it is in the range where many of these fail by worn out friction parts. Often, there is no hint of impending failure due to the automatic shift adjustment of that transmission. The servos have extra stroke and no external adjustment. The controller adjusts shift timings of the clutches and bands from inputs it receives from position and speed sensors. When the friction faces wear down, it can no longer maintain functions.

If you find problems when the tranny is cold, like sitting overnight at 15F or colder, but begins to work ok after the tranny fluid warms some, or you don't see the problem if the ambient temperature is warmer, say 45 F, the it is likely the seals on the shifting valves. Seals shrink when cold and if worn will leak excessively. These produce a variety of symptoms depending on which ones are the offender.

When this transmission was first introduced, there were reports of electrical conection problems both at the control module and at individaul connectors on the transmission. Sometimes, a connector problem at the controller box could be helped by exercising this connector by unplugging and pluging in several times. You may wish to unplug this conenctor and look at its condition. (It has a large number of pins.) If it is in good condition, its probably not the fault.

My advice is to take it to transmission repair shop (or dealer) that you trust and have diagnostics made. Sadly, I suspect that your transmission is badly worn. The quick repair is to replace it with a re-manufactured unit. The cost is about the same as a rebuild on your tranny. Make sure there is a warranty with the replacement unit.

I highly recommend it be repaired/replaced. A young tech at a brake shop threw two rods on my engine when the tranny failed to grab a gear during a test drive. I think that he inadvertently shifted from D3 through D to Neutal (this was very easy to do) and oversped the engine, but he swore not. There was no way for me to prove what happenend. One rod went through the block and the other holed the pan and was was laying in the street. The engine was junk. It was the most expensive brake job I ever had.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here