Return to the Cars Forum | Post a Follow-Up

 o
AC not cooling after radio install??!

Posted by melissag (My Page) on
Sat, Aug 19, 06 at 20:57

Hello,

I have a 97 Toyota Corolla DX. My radio went out a few weeks ago. Had a new one put in today. AC was blowing fine before dropping off the car. I got the car back with new radio installed(same voltage), noticed on the way home that the ac was blowing hot air. All the lights on the dash, radio, power windows locks, sunroof and alarm all are working fine. I noticed that the light on the ac button are off and also on the defrost button. Hazard lights work also. I really don't know much about cars and neither does my husband. Took it to autozone and bought new fuses and thats not the issue either. I am wondering is it maybe a compressor or condensor problem? Also do you think its just a fluke that this happened after the radio install or did they accidentally bump something or not plug a wire back in? Having no ac in the middle of August around here can suck major potato's. Any help would be greatly appreciated, otherwise hubby will have to take off work and take the car to our mechanic on Monday.

Thank you,
Melissa


Follow-Up Postings:

 o
RE: AC not cooling after radio install??!

sounds like they knocked the conection loose on the a/c switch.


 o
RE: AC not cooling after radio install??!

I hope thats all it is :( Is that hard to fix?


 o
RE: AC not cooling after radio install??!

Take it back to the guy who installed the radio and tell him that you think something was disconnected or got knocked loose on the A/C unit. Explain that it stopped working right after the radio was installed. Would he please check it out.

If he can't or won't help, then you are stuck with taking it to someone who is familar with your vehicle and in particular, its heating and A/C systems.

Likely, the problem is something disconnected - could be a vacuum line that got pulled loose.


 o
RE: AC not cooling after radio install??!

Yeah thats what I was going to do Monday since they are not open Sunday. I always forget to check that stuff before I leave.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here