Return to the Cars Forum | Post a Follow-Up

 o
MAF suspect

Posted by joe_mn (My Page) on
Fri, Jul 1, 11 at 10:33

99 grand prix. maf died last year. got used one. car died a few days ago at store. kids car. went to check it out and it started fine. told kid about unplugging sensor as a test. car died yesterday. kid called. said they unplugged it. but than plugged it back in. did not mention the last part. car would not start. killed battery. got a jump from friend. car started. friend left. car died. battery is still dead. maf is still plugged in. i am 1hr away. got my jumper cables and headed out. kid called back. friend came back. unplugged maf. car started and ran fine. kid went to their house. what a comedy of errors. now, pay $125 for new maf sensor.


Follow-Up Postings:

 o
RE: MAF suspect

got another maf. car runs fine now. yes, it is plugged in. we will wait to see if any other issues or stalling show up.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here