Return to the Cars Forum | Post a Follow-Up

 o
Caravan radiator fan malfunction, need advice.

Posted by vgkg (My Page) on
Thu, Jul 19, 07 at 7:52

Hi Folks, it's been a while.
Here's my situation :
1998 Dodge Caravan, nothing fancy.
About a year ago I noticed that the fan (2 electric fans) kept running after I turned off the motor, these would not shut down but would have kept going until the battery went dead. Both fans have a plug which I could easily unplug so (being cheap) I would just use 1 fan whenever I used the AC (it never overheated without the AC). This practice went on for over a year (only took 5 seconds to plug in the fan) until yesterday. I plugged in the fan before driving with AC but the fan did not come on. At first I thought that maybe the relay switch finally kicked back in, but not. The radiator will over heat now and both fans will not work at all.

I'm assuming that the relay (or whatever) finally gave way and broke down 100%? Any other opinions on what may be the problem would be greatly appreciated. If easy to remedy I could repair or replace the broken component myself assuming I can locate it, otherwise there's a Dodge dealership just 2 miles away. Any suggestions?
Thanks for any ideas, opinions, or advice!


Follow-Up Postings:

 o
RE: Caravan radiator fan malfunction, need advice.

I'd take it to the dealer, or at least call and ask. There's a recall of a number of chrysler vehicles of that year related to cooling fan/relay problems.

DR-1158 Chrysler 769 V 6/4/98 1997 & 1998 Dodge & Plymouth Neon vehicles built from V1 1997 through 9/9/98. (Fed)
97 VCR2.0VJGFEL
97 VCR2.0VJGKEK
97 VCR2.0VGFEM
(CA)
97 VCR122VJG1EK
97 VCR122VJG2EK
97 VCR122VJG1EL

(Fed)
98 WCRXV02.0VB0
98 WCRXV02.0VB2

(CA)
98 WCRXV0122V20
The solid state fan relay may fail because of heat related electrical over stress causing the fan to stop and the vehicle to overheat. (Fed)
40,000**
(CA)
10,000


 o
RE: Caravan radiator fan malfunction, need advice.

I have replace the relay twice and have the same problem
the check ingine lite comes on and tell me it is the same thing over and over.
the relay doesn't fix the problem not yet any way.

the other thing is the liter socket don't work and the fuse is good?????


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here