Return to the Cars Forum | Post a Follow-Up

 o
Land Rover Discovery 2003 noises HELP!

Posted by arianaciara (My Page) on
Thu, Jun 9, 05 at 15:59

Hi:

My Discovery makes the following noises: When I press on the gas, a whrrrrring noise, seems to be coming from the front of the car, let the pedal go, no whrrrrr, press pedal, whrrrrr.....and the other on is also when I press on the gas, while I'm driving, and I slow down to change lanes, I hit the gas and I hear a clunking noise, everytime.

Any thoughts....???

PS: Bear with me on the descriptions!!


Follow-Up Postings:

 o
RE: Land Rover Discovery 2003 noises HELP!

The clunking noise could be the torque converter clutch in the transmission unlocking when you step on the gas. Often when you lift your foot off the gas pedal, the torque converter will unlock when you put your foot back on the pedal to improve acceleration. It should not be a loud clunk, though, so maybe there's a problem in the transmission. If so, that might also explain the whirring sound. Have you checked the transmission fluid lately to see if it might be low due to a leak?

Since this is a 2003, hopefully it's still under warranty. If so, I'd take it to a dealer and have it checked.


 o
RE: Land Rover Discovery 2003 noises HELP!

You didn't specify if you have 4 wheel drive; do you? If the 4 wheel drive was engaged, the noise could be comming from some of those parts.

Get help from a shop person who is familar with the sounds of worn drive line parts of you particular model of vehicle.


 o
RE: Land Rover Discovery 2003 noises HELP!

OK I have the exact same problem. I haven't talked to a mechanic yet, but when I coast for a second or so and then press on the accel. I get the clunk. Also I get a kind of whistle when the gas is pressed at higher speeds. I have an '02.

arianaciara did you find anything out? if so id really like to know. email me


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here