Return to the Cars Forum | Post a Follow-Up

 o
1986 Jeep Ranger

Posted by briguy86 (My Page) on
Tue, May 6, 08 at 17:26

I know basically nothing about cars but my friends know a little and i would just like to know if anybody could spot the issue based off of this video

i did not run it for a while and when i went to start it up it did not work.. i put gas in it to see if that was the problem because it was near empty but had no luck turning it over.. tried the battery but no luck with that..

Here is a link that might be useful: VIDEO


Follow-Up Postings:

 o
RE: 1986 Jeep Ranger

Charge the battery. It's dead.


 o
RE: 1986 Jeep Ranger. One other thing

with your admitted lack of car knowledge you might want to
check the liquid level of the battery before charging it.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here