Return to the Cars Forum | Post a Follow-Up

 o
AC on my '98 ChevS10

Posted by urlee (My Page) on
Sat, May 12, 07 at 9:39

My auto airconditioner blows very cold air when first turned on.
After about 15 minutes warm air comes through the vents?

I turn the AC off and wait about 15-20 minutes or so, then it blows cold air for awhile then turns to warm again.

The mechanic who changed my oil, added a can of freon but that didn't do anything.

Any thoughts on what is happening?

Thanks,
Urlee


Follow-Up Postings:

 o
RE: AC on my '98 ChevS10

probably just a bad low pressure switch they are relatively cheap and easy to change out I would try that first. If that does not cure it check the compressor clutch air gap it may need adjusting and will not engage once the engine has warmed up. Other than that you will need a set of guages to check the low side high side pressures, to do further diagnosis.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here