Return to the Cars Forum | Post a Follow-Up

 o
1996 Nissan Maxima Stalling

Posted by ggalv (My Page) on
Sat, Apr 17, 10 at 9:59

Right now when the car is near a stop or getting ready to slow down the car stalls. The motor heads were just replaced recently.

After this work was done on the car, I noticed that the check engine light was marking the mass air flow meter (MAF). Not sure if this problem had already been there or if it happend just after maintenance on the car since the check engine light had already been there.

So, I replaced the MAF. The new MAF seemed to work fine for awhile. But then later on after the water pump was replaced the mechanic said that the MAF was not working again, basically he showed me that when the car is on and the MAF is disconnected the car runs fine, BUT when he disconnected the MAF the car turned off.

So, I went to the shop and they replaced the MAF. I tried driving the car a little, and noticed that it was stalling at red lights and also when I was trying to park.

I really appreciate if you guys/girls can help me out in trying to figuere out this problem. Not sure if I have a bad MAF or if its another problem.

THANKS


Follow-Up Postings:

 o
RE: 1996 Nissan Maxima Stalling

Have the trouble code(s) been read?


 o
RE: 1996 Nissan Maxima Stalling

I have the same problem replaced the MAF, fuel pump the car still stall


 o
RE: 1996 Nissan Maxima Stalling

GM has an engine shut-off problem on many of their models. It is associated with a certain make of ignition switch. The problem is aggravated when weights hang from the key. Some folks have a load of stuff fastened to their keys. This problem may relate to yours.

Does a load of stuff hang on your key when it is in the ignition switch?

This problem likely does not show when the car is new, but develops as wear sets in.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cars Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here