Return to the Cooking Outdoors Forum | Post a Follow-Up

 o
Members Mark Y0660 - Diappointing Heat Level

Posted by crly (My Page) on
Sun, Oct 20, 02 at 22:18

I purchased the Y0660 grill from Sams last week and WOW...what a grill. I tried it out last evening, but was disappointed with the heat level reached. Actually, after 40 minutes the hood thermometer reached just under 300 degrees and a flat on the grill thermometer only reached around 350 +/-. I took the burners out and cleaned them of obstructions per the directions (none present), but still can't get the heat level up.

I put a couple steaks on and couldn't get them seared. I tried using only one of the three burners thinking this might help, but no luck.

Is there a break-in period on these grills? Any thoughts on what I might be doing wrong or how to remedy this problem would be appreciated. I've seen messages with users talking about getting their grill to 600. I don't really need it that hot, but getting it up into the 500 + level would be nice.

Look forward to feedback.

Crly in St. Louis, MO


Follow-Up Postings:

 o
RE: Members Mark Y0660 - Diappointing Heat Level

Something is wrong with your grill. I hit 600 F the first time I used mine. Quite possibly, it's the regulator. Call Grand Hall today and explain the situation or just return the grill for another one, if that's possible considering the weight and size. Hang in there, once resolved you will love that grill. -Terry


 o
RE: Members Mark Y0660 - Diappointing Heat Level

Try turning the valve on your lp tank on very slowly. The new tanks need to be turned on slowly or else the safety mechanism kicks in, reducing the gas flow.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cooking Outdoors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here