Return to the Cooking Outdoors Forum | Post a Follow-Up

 o
ignitor not working on Virco....help

Posted by superflygrillguy (My Page) on
Mon, Oct 7, 02 at 12:01

Just got my Virco Classic. Overall was pretty happy. When I first fired up, everything was working great. Then I left it on for about 5 minutes and turned it off. 20 minutes later I tried to fire it back up and only the far right could ignite. There were no sparks from the other ignitor. I had to hand light the other two.

I am using LP for now while waiting for the conversion kit. Yes I did open the tank slowly.

Thanks for the help


Follow-Up Postings:

 o
RE: ignitor not working on Virco....help

Superfly,

My igniter on the side burner was disconnected underneath. It is just a clip-on deal so if that's what is wrong with yours it should be a very easy fix.

Look for a wire running from the ignitor button up to the underside of the burner and make sure they are connected.

I think they get loose during shipping.

Made an awsome marinated tri tip from Costco Sat night. The leftovers made great sandwiches!

Good luck.
Deeta


 o
RE: ignitor not working on Virco....help

It is connected. As I said, it worked the first time, but never since.


 o
RE: ignitor not working on Virco....help

I had a defective ignitor that went out after a few weeks. No spark whatsoever. If you don't get any spark, yours could be defective. Call Virco and ask them to ship you a replacement. It's not too hard to replace, but I had to loosen that side of the front panel to get enough space to ease the ignitor out.

Another possibility is that the gaps between the ignitor wires and the burners need adjustment. However, I went through a lot of such adjustments, then ignitor finally died, and the replacement has not needed any adjustments.


 o
RE: ignitor not working on Virco....help

You could also elimate the question of the ignitor module by unhooking the wires that don't work and moving the one right hand side ignitor to the other terminals. This would answer this question for you. This is easily accessed under the front panel. Even though it worked at first and not after you ran it for a while, this might be an expansion issue and you might just need to further adjust the electrodes. My guess is that the ignitor may be fine. I too had to do some adjusting on the electrode tips to get a good spark. I found that a quarter inch of clearance worked really well. I also put a new duracell alkaline in the button, it sparks alot better. One more area of cocern may also be the position of the spark in relation to the burner tube holes. (Assuming the module is ok) What I mean is this. I found that when I was running propane, I bent my electrodes so that the spark was underneath the outlet holes on the burner tube. Since LP is heavier than air, the gas was going down and accumulating before it would ignite, making a small combustion. Consequently, when I converted to NG, I had to reverse this and make the spark above the holes. Lights immmediately now. Good luck.


 o
RE: ignitor not working on Virco....help

Adjusted electrodes and now works fine. Thanks.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cooking Outdoors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here