Return to the Cooking Outdoors Forum | Post a Follow-Up

 o
problem with Gas grill.

Posted by bixll (My Page) on
Sun, Jul 8, 07 at 19:54

I have a Great Outdoors, Pinnacle model gas grill purchased from Lowe's a couple years ago. It is a 4 burner, model. I have never had any problems with it until today. I ran low on gas, so I changed tanks. With new tank, I can only get a very low flame, even though all 4 burner knobs are on high. I had 2 other full tanks that I tried that I got the same results. These tanks are exchange tanks, by Amerigas, that have new valves, and are spiffy clean new looking.

Any ideas/suggestions???


Follow-Up Postings:

 o
RE: problem with Gas grill.

Are you turning the tank on very slowly? If not the valve inside will shut or partially shut causing a starvation of gas going to the grill.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Cooking Outdoors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here