Return to the Basements Forum | Post a Follow-Up

 o
Dehumidifier Setting

Posted by drbmw90 (My Page) on
Fri, Sep 11, 09 at 11:08

I just purchased the Danby Premiere dehumidifier. Not a lot of instruction on the settings. I need the highest setting to pull out as much water as possible. I turned it on to the factory settings and it didn't pick up any water all night. Please let me know if you have any ideas. Thank you.


Follow-Up Postings:

 o
RE: Dehumidifier Setting

I think mold etc grows at around 65%+ i put mine on 50% and it pulls alot of water out of the air. Maybe 50% is too low? but you could try it and see.


 o
RE: Dehumidifier Setting

DH sets ours at 50-55%.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Basements Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here