Return to the Appliances Forum | Post a Follow-Up

 o
Problems with electrolux 30" electric double wall ovens

Posted by Schultzd4 (My Page) on
Thu, Dec 19, 13 at 9:05

Has anyone experienced problems with their Electrolux double wall ovens? I purchased an Electrolux double wall oven and had them installed in late February of this year (2013). In April the convection fan in the bottom oven stopped working so had service come out. They schedule a visit to determine the problem, order necessary parts, and then come back a couple weeks later to install the parts. This was a minor inconvenience considering I could still use both ovens but I was annoyed that a new oven (less than 2 months) would need any "new" parts (all the parts should be new and working on a new oven!). Now on December 16th the whole thing just went dead. I was baking a cake in the top oven at 350 and broiling chicken in the bottom oven when it just died. No response on the control panel, no interior lights, no heat! The handle to the top oven was super hot as was the control panel. The trim on the control panel even started to separate. Service says they will have to order some parts before they will even come out this time so thinking I am at least 2 weeks away from having an oven. This is a major inconvenience since nothing works and now there will be no Christmas baking or our traditional Christmas eve ham dinner with family. I am really angry! Has anyone else had similar problems?


Follow-Up Postings:

 o
RE: Problems with electrolux 30" electric double wall ovens

A similar situation with no oven Thanksgiving through Christmas with brand new range and oven. This was after 7 months of tinkering and (non)fixing. It was a different brand and eventually they bought them back as they never could get them to work. It was one of the most frustrating things. My sympathies are with you.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here