Return to the Appliances Forum | Post a Follow-Up

 o
Thermador Freedom Freezer--Can't Get Ice Working

Posted by kristinar (My Page) on
Fri, Oct 12, 07 at 22:24

We just had our Thermador Freedom Frig and Freezer installed. We can't seem to get the ice maker to work. Our contractor says the water line is hooked up and we pushed the ice maker button to turn it on but no luck. I'm hoping there is a simple solution that we missed--like a switch that needs to be flipped??? I looked at the directions but didn't find any additional information.


Follow-Up Postings:

 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

If you find out the problem, please post. I'm considering purchasing the freezer thanks


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

You didn't say which models you have but I've installed a few of these.
1. you need to see the word ice in the control display.
2. your bucket needs to be locked in place and fully pushed back.
3. most Icemakers won't produce ice until the Freezer has been running several hours. I usually tell my customers that they wont see ice until 12+ hours have passed. The Freezer need to get cold enough for ice and the icemaker needs to cycle a couple times before water gets to it.
4. the Freedoms seem to make their fastest ice production when the freezer is set for -4F. At least thats what their techline told me.
5. Is the water actually turned on?
6. Is the filter fully turned and locked into place? I have seen a couple units where the filter was not fully turned to lock and that shuts the water off.

I hope this helps
Jakvis


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

Jakvis--thank you for your response. We have the T24IF Freezer column. I'll double check that the bucket is locked in place. It seems like it is pushed back all the way. I'll also check the water filter--I didn't even realize it had that. My contractor is going to double check that the water valve is on later today, but in the meantime, I'll try the tips you mention. Thanks again!
Kristina


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

The ice bucket can seem like it's back all the way and still not trip the button that will release ice. To make sure, get dow so that the ice bucket is at eye level and look through so you can see the back wall through it. There is a horizontal switch that is triggered to let ice release. Make sure you can see it flip as you puah the bucket in. You may be able to feel the bucket lock into place too. It might seem like a second stop.


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

Did you get it working?


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

Lascatx--thanks for the additional info. Yes, I got it working. I'm not sure if it was my turning the water filter cartridge or pushing the ice bucket back--but we have ice. I'll take a look again at what you suggested with the ice bucket--just to see what you mean. I hadn't seen your post when I messed around with everything. But I'm glad to have all of these tips! Thanks so much!!


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

Glad you have ice. I think the drawer not being far enough back is the number one problem. It has to click into place, not just glide back, for the ice to dump. If the drawer is full or nearly, it doesn't matter so much, but when my son takes his galon water jug to band practice every day, it matters a lot by the end of the week.

Enjoy!


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

I purchased a freedom freezer in August. The icemaker never
worked. I had to wait for 6 weeks to get a new icemaker.
When it came the technician told me the cable for the icemaker was not hooked up to power.
There is a cable near the filter that has to plug in.
I hope this help.


 o
RE: Thermador Freedom Freezer--Can't Get Ice Working

My freezer column is about 5 years old - stopped making ice - changed filter and still not making ice - any ideas?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here