Return to the Appliances Forum | Post a Follow-Up

 o
GE pss26ngpa bb fridge problem

Posted by shannon01 (My Page) on
Sat, Sep 21, 13 at 15:40

So my GE fridge is behaving strangely.
The temperature on both fridge and freezer keeps rising.
The light for the Express Thaw is lit up on 3lbs.
I have reset fridge, turning it off all the way, but it stays ok for only a day or two, then back to rising temps.
I regularly clean the back of it and will again.
Anyone have any ideas short of purchasing a new one??


Follow-Up Postings:

 o
RE: GE pss26ngpa bb fridge problem

How long do you leave it off when doing a "reset?"

Your Express Thaw controls won't go to any other setting?

Is the condensor fan running (warm air blowing from the bottom front)?

Is the evaporator fan running inside the freezer section?

Possibly a problem with the defrost components ... heating element, temp-limit sensor or some such. If it doesn't defrost on whatever is the normal period, the cooling coil will get "clogged" with frost accumulation which obstructs airflow.


 o
RE: GE pss26ngpa bb fridge problem

I opened up back, got all dust out.
The fan was coming on and off, temps still rising.

The Express Thaw light stays lit to 3lbs.

I reset the cood/warm buttons inside fridge. It says to hit warm until it says OFF. Then hit one of the cool buttons and it should reset. Didn't do a thing.

Then I read online that you unplug, replug in, switch icemaker off then on, then push the ice lever 3 times. This is supposed to reset to factory settings.

Now the fan will only come on if you open a door. Once shut, it turns off.

Both freezer and fridge say 68 and nothing is coming on anymore.


 o
RE: GE pss26ngpa bb fridge problem

Can also be a bad motherboard. Everything about this unit -- compressor, defrosting, all the fans -- is controlled by a computer board, mounted behind a panel on the rear.


 o
RE: GE pss26ngpa bb fridge problem

Then I read online that you unplug, replug in, switch icemaker off then on, then push the ice lever 3 times. This is supposed to reset to factory settings.
I believe the purpose of this procedure is to manually trigger the ice maker to run a harvest cycle ... and has nothing to do with operation of the refrigerator.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here