Return to the Appliances Forum | Post a Follow-Up

 o
A Blue Star Success Story

Posted by Dougald (My Page) on
Fri, May 4, 12 at 16:52

For every brand and type of appliance, there are horror stories - these threads are filled with tales of things gone wrong. But just once, I want to report a success story.

Ordering a BlueStar range was a financial no brainer for me here in Canada as the Costco 36 inch version is just over $3000 (I noticed that Costco executive members can now get a further $500 off) and is wayyyy less than anything else available. I ordered mine online in December and it was delivered within a week - it sat on its pallet until early April awaiting installation in the newly renovated kitchen.

With the install scheduled with the gas techie a week away, I opened the carton. To my dismay, it was missing the heatguard. On a monday morning, I called BlueStar (calling Costco is pointless!). The customer service told me they would ship the missing sheetmetal and I would have it Thursday ... across the border and all. I remembered all the stories here on GW and just thought ... yeah, really ... But lo and behold, Thursday afternoon the package with the heatguard was in my hands.

The range was installed the following monday - the gas technician did a good job and was very familiar with the model. He checked everything and left me with the confidence that all was well. The range has been operating now for only a few weeks so too short to say it will last BUT so far, the range and the Kobe hood have performed perfectly as advertised.

Maybe BlueStar QC should ensure the whole unit is shipped complete but kudos to their customer service for putting right their error on very short no hassle notice. And my thanks to BlueStar and Kobe for providing quality products at a reasonable price.


Follow-Up Postings:

 o
RE: A Blue Star Success Story

I wish our Costco (in the states) sold BS. :( I'm glad to see you had a good experience.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here