Return to the Appliances Forum | Post a Follow-Up

 o
possessed kenmore sucker upper

Posted by cuffs054 (My Page) on
Tue, May 20, 14 at 15:28

My Kenmore Blue Progressive canister vac appears to be possessed. It has the power hose with controls on the handle. Vac works great but won't shut all the way off. After use sliding the switch to off shuts everything off FOR awhile. If left plugged in it will begin to "bump" start over and over. Soon it will begin to run at half speed and must be unplugged. It does not energize the power head when it does this. Even if I pull the hose out of the canister it will continue its trick. Any thoughts?


Follow-Up Postings:

 o
RE: possessed kenmore sucker upper

If it's under warranty, bring it in for a repair. If not, unplug it when you're done using it - sounds like something in the switch mechanism is sticking.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here