Return to the Appliances Forum | Post a Follow-Up

 o
water in new dishwasher

Posted by scpalmetto (My Page) on
Thu, Apr 10, 14 at 11:37

Our appliances for a kitchen reno were delivered yesterday. They will not be installed for at least 2 weeks but our cabinet installer wanted them on site in case of any problems. Everything looked fine on arrival. This morning I opened the dishwasher and found water inside. There was a musty mildew smell also. I called our appliance store and was told there is always some water in dw's as they are tested at the factory. I have bought 7 dishwashers over the years and have never seen this before. I really do not think this was a returned unit, it is clearly brand new. Is it me or is this normal???


Follow-Up Postings:

 o
RE: water in new dishwasher

not unusual in my experience.


 o
RE: water in new dishwasher

I know Miele and Bosch test every unit and may have residual water.


 o
RE: water in new dishwasher

Yes your salesperson is right, manufactures will do quality test runs on dishwashers and clothes washer. So yes it's normal.


 o
RE: water in new dishwasher

I had an Amana range delivered in the 90s from Best Buy that came "new" with a burnt pizza in it; yeah wasn't happy and never accepted another unboxed appliance again.


 o
RE: water in new dishwasher

I had the same problem with a brand new Bosch 800 series dishwasher. I used LemiShine dishwasher cleaner and the smell disappeared.


 o
RE: water in new dishwasher

Have purchased a new bosch and a whirlpool(although it was an open box deal) within the past six months and both have has some residula moisture in them


 o
RE: water in new dishwasher

I recently visited an appliance store and noticed one DW had standing water. The salesmen told me it had just been delivered to the store the day before, and the water was from the manufacturer's test run.


 o
RE: water in new dishwasher

Our new Miele has a bit of water inside. It was made less than 3 months ago. No worries.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here