Return to the Appliances Forum | Post a Follow-Up

 o
Dishes on Top Rack Not getting Clean

Posted by onlygirlsmom (My Page) on
Sun, Mar 18, 12 at 21:20

We have a Whirlpool DW (model #DU1055XTSS2)that is not cleaning the upper rack. I think I have discovered that the upper arm is not spinning. I am currently running a cycle with vinegar to see if that cleans out any gunk that might be clogging the water holes. The dishwasher is about 4 years old. If it is indeed the upper arm -is this something that I can fix myself or is it a mechanic type repair?
I'd rather get it fixed vs getting a new machine as we are going to be putting the house on the market soon.
TIA!


Follow-Up Postings:

 o
RE: Dishes on Top Rack Not getting Clean

Is it an adjustable rack? If one side is higher/lower than the other, the arm won't spin.


 o
RE: Dishes on Top Rack Not getting Clean

Other possibilities:

1) The fill valve may be clogged with debris/sediment from the household water supply. Fill is timed, so if the incoming water flow is weak the water level won't be sufficient in the allotted time to keep the pump pumping strong. Not an unusual situation. The valve can be disassembled for cleaning the sediment screen. I did that for a friend several months ago.

2) There is a screen in the pump that's part of the food chopper assembly that can get clogged with stray material such as fibrous food residue, paper jar labels, bits of bone or other debris, even glass fragments if there has been a breakage ... which will impede water flow into the pump and cause weak spray from the arms. There are videos on YouTube showing how to access and clean the area.

3) Tablet detergents and gelpaks can sometimes cause excess sudsing/foaming which impedes water flow through the pump and spray arms.


 o
RE: Dishes on Top Rack Not getting Clean

When this has happened to me in the past with my KA (made by Whirlpool), it has been #2. You will need a Torx driver to remove the screws. I forget which size.

BTW: when the machine is running, you should stop it and open the door and check the water level. It should be caressing the heating element.


 o
RE: Dishes on Top Rack Not getting Clean

I'm going to assume the water level is OK and pump is OK because you didn't say the lower rack isn't getting cleaned. I'd be surprised if they weren't OK, but I'm not at all discounting advice above. I'd also be surprised if the spray-arm itself was clogged but that, too, is a possibility. I suspect the cause may be simpler.

I suspect the upper spray arm isn't being pressurized. Why would it not be pressurized? Usual causes are 1) it's supply tube is not engaging and sealing with the hole in back that supplies it and/or 2) the little rinse-spinner up on the ceiling of the interior has broken off and its supply-hole is gushing thereby bleeding off pressure that would normally go to the spray-arm. Both are quite easy to check.


 o
RE: Dishes on Top Rack Not getting Clean

When ours had this issue, we found that the plastic piping that supplies the water to the upper spray arm had somehow come unsnapped from it's support & as a result it was not coming into contact with the water supply line at the back interior dishwasher wall. Take a look at your plastic pipe that is attached to your upper spray arm and follow it to the back of the upper rack--is it dangling a little low or is it attached to the bottom of the upper rack by a support? If it's dangling, just put it back in it's support
(which should be attached to the upper rack) and you are good to go.


 o
RE: Dishes on Top Rack Not getting Clean

Thanks for all your help!! My husband seems to have fixed it while I was out last night (he told me the bill is in the mail :)) He cleaned out the disposal/filter area. We've run one load and it seems to be 100% back to normal.
You guys were far more helpful than the Whirlpool online help desk -they were useless! I swear they use robots! My husband showed me his conversation with them. He asked them if there could be some sort of filter that might be clogged and all they said was "I'm sorry. I'm not a technician. You can call one of our technicians out to come look at it." And they said it several more times. Worthless! I have honestly not been super excited with our WP products (our fridge has the ice maker in the door-HUGE design flaw) Unfortunately, DH's brother works for WP (executive) so we're probably stuck with their products for now :(
Thanks again!


 o
RE: Dishes on Top Rack Not getting Clean

Thanks for coming back with outcome. We don't get enough of that .


 o
RE: Dishes on Top Rack Not getting Clean

"....we're probably stuck with their products for now...."

"He cleaned out the disposal/filter area.....it seems to be 100% back to normal."

To be fair, I don't think it's reasonable to blame the product/mfgr if the cause of your problem was a filter that hadn't been maintained. Would have/could have happened with any machine.


 o
RE: Dishes on Top Rack Not getting Clean

Actually, the 'filter' in this design is not a maintenance item like for the Bosch or other non-grinder designs.


 o
RE: Dishes on Top Rack Not getting Clean

@weedmeister....

Got me. Should have looked it up before responding. Tee'd off on OP's mention of "filter".

Owned one of these whirlpool designs for almost ten years without a problem, though. (In the end a relay on the main board failed.) Still have one running like new after 13 years at another location.

Anyway, glad the problem's solved....and glad to learn it didn't require hired tech.


 o
RE: Dishes on Top Rack Not getting Clean

sorry for the confusion -I probably misused the word "filter". My husband took apart the bottom arm and cleaned out the area where the disposal is.

And I'm not blaming the mfgr for the problem, my complaint is with how useless their online support is. Maybe they're not allowed to answer any "tech" questions?


 o
RE: Dishes on Top Rack Not getting Clean

Front-line phone reps typically don't have access to technical information.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here