Return to the Appliances Forum | Post a Follow-Up

 o
Miele Chef Oven Update

Posted by sarends (My Page) on
Thu, Feb 7, 13 at 13:52

We bought a floor model Miele 30" Chef Oven about three weeks ago. All good so far.

Tested temperature yesterday - set to 350 and Oneida Digital probe on rack measured 341 - I ordered another thermometer to check it as well

All meals prepared by DW have been excellent - all getting done according to schedule and have been wonderful

Observation 1- the door of the oven does not get very warm at all when it is running - this is a pleasant surprise compared to ovens we have owned prior

Observation 2 - The timer is hard to set - you hold a digital arrow and it either goes too slow or too fast - it is very easy to go past where you want to set it at and then backing up is difficult.and only goes a max of 99 minutes.

Observation 3 - We knew this from our speed oven, micro and warming drawer, but DW is totally in love with the way the Miele stainless resists fingerprints.

I don't think we can do auto roast (there is no option for it in Chef model) which so many people love who have a Master Chef model - not sure we can replicate this or not - not even sure what auto roast does?

All in all, we are very happy with the purchase.


Follow-Up Postings:

 o
RE: Miele Chef Oven Update

There was another question here about Auto Roast recently; you might search (below) for that.

IIRC, after putting your meat into a room temperature oven, you would set the roast temp well beyond what you want, to sear the outside for a bit, then turn the temp back to whatever you want to roast at (the default is 320F, I think). That's what Auto Roast does automatically in the Master Chef models. It does not use the probe.

I'm not sure how much hotter that initial searing temperature gets, or for how long before it returns to your normal roasting setting. Perhaps someone who uses this feature can tell us.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here