Return to the Appliances Forum | Post a Follow-Up

 o
Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Posted by estreya (My Page) on
Sun, Jan 4, 09 at 22:58

Hello, everyone.

I have a KitchenAid refrigerator which has an automatic water and ice dispenser built into the door. Yesterday, i noticed the ice maker is no longer making ice.

Since the filter was changed yesterday morning and all the ice was dumped out, i thought perhaps it was just a matter of time before it produced enough ice to fill the bucket again. But a day and a half later, there's still no indication of ice being made.

Additionally, there's a red light on the inside to the right of the mechanism (where the on/off switch for ice is) that's blinking. I would swear this light stopped blinking just after the filter was changed, but it seems to be blinking again. I took the filter out and pushed it in again to see if that might help, but it's still blinking.

Any thoughts on what kind of "fix" i'm looking at? Not long ago, my KitchenAid dishwasher door broke, and ended up paying over $200.00 because i felt i couldn't do it myself. I really don't want to have to make a service call if it can possibly be avoided.

Thoughts? I'm cross posting this on the kitchen forum to get as many expert eyes on it as possible.

Thank you all,

wondering-why-appliances-aren't-built-to-last-anymore


Follow-Up Postings:

 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Did you run the water dispenser per the filter installation instructions to clear residual air pockets?


 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Wow, dadoes, thank you for such a prompt response! Yes, the air pockets were cleared, and the water's been running really well. That's part of what's puzzling me so much. I can't understand why the water dispenser would work fine, while the ice maker suddenly stopped.


 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Look at the icemaker, and the fingers that knock the ice out should be looking at you. They should be actually just above the horizon. If they are not replace the motor module on the icemaker. If so look at the black tube, where the water comes into the icemaker. Squeeze it, if it is hard, it is frozen, if it is soft, then you would have to replace the emitter kit. If you need parts, or some more instruction, I can help. Tom www.applianceeducator.com

Here is a link that might be useful: parts


 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Was it working before you replaced the filter? Check your manual for what the blinking red light means - it could be something simple like pushing a reset button or turning something back on. On my KA, after changing the filter, you have to push a button for ten seconds to reset the red light.

Yours looks something like mine - with the little swinging door and the electric eye to see if the bin is full. Make sure you're not blocking any of those - that tells the ice maker to shut off.


 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Thank you so much for all your thoughtful responses!

I'm pleased to say i awoke this morning to see ice had collected in the bucket. Last night, i used a hair dryer (of all things!) to melt some ice that had hardened around and within the black rubber tube that apparently feeds water into the ice tray. Although i'm not entirely certain this will represent a long-term fix, for now at least it seems i may have dodged this home-maintenance bullet.

Thank you again for your thoughts everyone, and have a great New Year!


 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

Yup - that's a common problem - I haven't had it with my current (6 year old KA) but it happened a number of times on my previous Whirlpool fridge. I didn't think it was your problem since you were getting water ok but I guess the freezing occurred after the water split off.


 o
RE: Automatic Ice Maker on Fridge Isn't Making Ice (4 Pics)

I have the same problem in my KA ref, just like yours. KA will not do anything about it. I had them out 3 times prior to the end of warranty and the problem was never fixed. It occurred again after the warranty was out. You guessed it. It's now my problem.The problem with mine, I figured out, is the pressure from the water filter is not great enough when the filter gets old. The fill tube (black tube in freezer) freezes up. I have taken the filter cartridge out and for the last year have had no problem. Our municipal water is very good where I live so I am not worried about quality issues. I would use a better inline filter on my water line if I were concerned.

On my first service call, the tech did say that KA had repaired "hundreds" of these units like this. Unfortunately the "like this" that he did to my unit did not work.

I am planning a buildout on my garden level that will include a snack bar which will have a ref. That unit will not be a KA.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Appliances Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here