options for reparing jandy rs8 controller thats acting up

rosstermanOctober 16, 2010

I have a Jandy RS8 wireless controller that is abouut 5 years old. The unit has been acting up over the last year- sometimes locking up or refusing to start up. I know the batteries are bad as it doesn't work without the charging cord being plugged in.

Wondered what options to fix it other than buying the way overpriced pc board or a complete new unit. Has anybody had this problem and corrected it by replacing the batteries? Has anyone had the board inspected/repaired by a repair shop. Don't want to spend a fortune fixing this thing and haven't been lucky enough to find one on the web used.

Thank you for reporting this comment. Undo

Weak batteries will obviously cause issues.

Have the issues continued with it plugged in?

Is where it gets plugged in possibly having reception difficulties?


    Bookmark   October 17, 2010 at 9:02AM
Thank you for reporting this comment. Undo

Is the wireless Jandy unit near a source of interference, such as a microwave or computer wireless access point/router? Both can cause communication issues with the older Jandy wireless controllers. As a test, take the unit out near your equipment pad and test with the controller near the sending unit (has antenna on it). If it's OK there, you may be facing an interference issue.

My unit would freeze/reboot every time I used the kitchen microwave.


    Bookmark   October 17, 2010 at 12:47PM
Thank you for reporting this comment. Undo

Thanks for the responses- I checked and tried in different areas (it wasn't near a microwave or rf device before) with no change. Acts like circuit board or chip is bad. Batteries may be causing but acts the same plugged in or running off the battery.

Read that some folks were able to emulate the controller on an ipad or iphone- probably cheaper and more reliable than spending $900 on a circuit board and hoping this corrects the problem. Anyone know anybody that had done this? I'd be willing to pay someone to purchase the code if possible

    Bookmark   October 18, 2010 at 9:35PM
Thank you for reporting this comment. Undo

Do you have a spa side remote???
If yes, disconnect your 6-pin connector in the power center and go into system setup and disable the spa switch.
If not, do you have a PDA PS8???
If yes, change the channel on your antenna by the power center.
If your not clear on how to do this post here and I or someone else can walk you through it.

If the answer is no to both these questions you probably have the old style RS8 One Touch wireless remote remote. See if you can determine the unit you have and post it here.

See ya,

    Bookmark   October 18, 2010 at 10:06PM
Thank you for reporting this comment. Undo

The controller is an 8156- the square black unit that ~5" x 5" square and is not waterproof. I have the spaside remote with the mutliple buttons that control the pool pumps, waterfall, garden lighting, etc. I'm not sure what's meant by disconnecting the spaside remote- it is to reset the unit? (I don't want to lose the controls at the spa).
Wierd thing is that I've had it unplugged from the charging cord while it's sat off for a few days and starts and works fine off the battery now. Wondering if keeping it on the charger all the time is part of the problem- maybe causing the voltage to be off. I did change the dip switched and the unit a couple of weeks ago to see if this was the problem but didn't help. Think the issue is the unit not booting up correctly rather than a connection to the main control system outside as the screen freezes or has lines running across the screen during start up.

Anyone tried using a iPad or iPod in place of this unit?

    Bookmark   October 24, 2010 at 1:37PM
Thank you for reporting this comment. Undo

Reason he wants you to disconnect the spa side is water gets in the switch and causes problems with the system. If you disconnect spa side wiring at the board and the problem goes away than you know the spa side is bad. For repairs on the board I use BP engineering up north. Bob is a former Jandy employee that had worked on the Aqualinks. Don't have a number right now but let me know if you need the info.

    Bookmark   October 26, 2010 at 10:34PM
Thank you for reporting this comment. Undo

Wanted to close this thread out as I have now rectified the problem. Took apart to see about replacing the nicads and rebuilt the batter pack using some new ones from Harbor freight (a pita to solder but cheap fix at $6 vs ~ $100 for the replacement pack) . Works great now- looks like the problem was bad batteries although the problem existed while plugged into the wall charger. Must be that the wall charger can't keep the voltage high enough with bad cells so thought was something else.

    Bookmark   December 20, 2010 at 1:54PM
Sign Up to comment
More Discussions
Transition between two DiamondBrite colors
Trying to figure out best way to do this. Will be doing...
Would you recommend Fibre Tech?
Anyone with Fibre Tech experience like to comment?...
should pool building take this long??
I signed a contract July 19th with Mr. Carlos pools....
How to film pool build timelapse?
I've been lurking for months & finally ready to...
Wendy Baldwin
Need help with sealing gunite to rock, and black alge
Hey friends! I purchased a house last summer in Houston,...
Klint Turney
Sponsored Products
Saipan Modern Fabric Recliner Club Chair
Casablanca Ceiling Fan Controls Universal Handheld 4-Speed Fan Control System
$40.00 | Home Depot
Flos | Kelvin LED Green Mode Table Lamp
$445.00 | YLighting
Home Decorators Collection Cushions Dorsett Cherry Sydney 3-Seater Outdoor
$75.00 | Home Depot
Jesse Upholstered Panel Bed - White - ELET300
$329.98 | Hayneedle
Jamie Young Large Borealis Alabaster Table Lamp
Lamps Plus
© 2015 Houzz Inc. Houzz® The new way to design your home™