Heater won't light

tonys_2009February 2, 2012

I have a Hayward 400k btu heater that is about 4 years old. When I turn the heater on the fan starts I hear a click and then a quick poof sound with some small flames comin out of the top. Its night time sothe flames are noticeable. I wouldn't be ble to see them if it was during the day. Does this maybe one more time and then it lights. I notice it happens more often if I go a week or so without using the heater. This just started a few months ago. Does something need to be cleaned?

Thank you for reporting this comment. Undo
goyom

YO Brochaco, does it have a read out ? Error code showing up on the screen? Sounds like a flame out sensor to my untrained sensibilities.

    Bookmark   February 3, 2012 at 7:43PM
Thank you for reporting this comment. Undo
tonys_2009

The plastic cover over the display panel came off and I guess blew away. I put some duct tape over it to keep rain out. Everything is connected to the jandy controls so I never use the keypad. I'll pull the tape off tomorrow and see what it shows on it.

    Bookmark   February 5, 2012 at 10:49PM
Sign Up to comment
More Discussions
Looking for Pool Builder recommendations in Pasadena, CA
We are starting to evaluate contractors but can't find...
julieleek
pool filter leak; newbies buying the house
We have a contract on a house with a pool. The pool...
defgarden
Baffled by my pool- peeling skim coat?
Hi all! My in ground concrete pool is leaking... I...
sabine77
blue stone pool deck
I live in Utah and am building a traditional east coast...
holly6
What pump are you using?
We have a 30,000 gal gunite in ground pool with a small...
lindamarie
© 2015 Houzz Inc. Houzz® The new way to design your home™