help with aqualogic ps-4

drexFebruary 26, 2009

Thanks in advance for any assistance that may be rendered.

I am a DIYer and quite frankly was not very happy after contacting Goldline to find out why "NO CELL POWER" is occurring on my PS-4 Aqualogic system. I am the second homeowner, and of course, its out of warranty.

Issue: No chlorine generation. Tried all the resets/service light/breaker off for 12 hours/etc.

I can hear the relay try to establish power to the cell, but then the error occurs. And the cell is not reading the sodium level (its 3200 per the pool place)... so , does anyone know if it is the CELL or the control board that is damaged?

Is there a way to indirectly or directly check the cell to see which one is the culprit??

(yes the cell is CLEAN, btw!)..

Any assistance would be IMMENSELY appreciated.

And no, after seeing the install work, I don't trust the local yocals to work on this.

I have a new PS4 logic board waiting for me at the pool pump places for $510; would like to hopefully replace the correct piece, and not spend any more than that.

Thanks again!

Thank you for reporting this comment. Undo

What's the water temp?

    Bookmark   February 26, 2009 at 6:58PM
Thank you for reporting this comment. Undo

Where are you located?
"No cell power" generally means no power to the circuit board. Did you check the fuse to the transformer? Do you have the means and ability to check the transformer for power out, around 24v. By ability I mean you have 240v that can kill you if you dont know what you are doing. If transformer is working then it is your board.
How old is the system. Warranty for three years.

    Bookmark   February 26, 2009 at 10:00PM
Thank you for reporting this comment. Undo

water temp 72-78 deg.

yes, i can check. checked both fuses-- they are intact.

yes, i can check the transformer for power out. I assume you mean the 120/240 to 24 v on the main unit. So if the transformer is working, then the board is bad??

How can one tell if the cell is bad, or when its time to replace the cell?

System >3 and Also, the unit is no longer able to read any salt level in the water.... I would assume this also due to bad board?

I'll get to this tomorrow, and post the results. Thanks so much so far for the help!

    Bookmark   February 27, 2009 at 12:30AM
Thank you for reporting this comment. Undo

This almost always requires replacing the GLX-PCB-MAIN.

    Bookmark   February 28, 2009 at 8:22AM
Thank you for reporting this comment. Undo

I am having the same problem. Unit is four years old. Aqua logic p4. My cell is good
i took it to a friends pool and we swaped it out. I am not showing 24 volts on the transformer and fuses are good. let me know what you find out. i will do likewise.

    Bookmark   February 28, 2009 at 7:59PM
Thank you for reporting this comment. Undo

Mike is correct.

Replaced the main. Had cell tested, it was good.

So, basically, replacing the main board will solve the problem. Apparently, this is very common. Replacing the board is easy. The question is sourcing, and the $$$ and warranty involved.

What I found out:

Our older cells come with a 5 year warranty. The new cells are all 3 years. And cost the same.

Regarding the board:

One national retailer: $875 (board only)

Local pool (small) shop: $525

Warranty, one year.

The board is the current board.

Or, for $875, I can buy the board, a newer display, same innards and associated sensors, and have spare parts/sensors, or ebay what I don't need (case, sensors, relays, etc)... with a 3 year parts, 1 year parts&labor warranty.

I spent the 875 for the system... replaced out the board, and the display (cause the new one is nicer), and 10 minutes later, viola, and cell works.... the software is updated, its better, and smarter (in terms of pool/spa capabilities, etc).

So, that's the deal-io. For better, or for worse!

    Bookmark   March 8, 2009 at 12:13PM
Thank you for reporting this comment. Undo

If your cell is original its life is short, I would look around the internet for a complete p-4 with salt cell. You can pick one up for under 1k. Less then new board, and new cell, and whatever else goes wrong it.

I swear these products self distruct after 3years.

    Bookmark   March 8, 2009 at 1:48PM
Thank you for reporting this comment. Undo


the above prices are parts only.


    Bookmark   March 8, 2009 at 4:57PM
Thank you for reporting this comment. Undo

cell is good for another 2 years; no issues there -- but thanks!!

    Bookmark   March 8, 2009 at 5:54PM
Thank you for reporting this comment. Undo

Read the fine print on the 5Year warranty, its prorated after 3. This basically means they will sell you a new one for more then you can buy one for. Good ole hayward.
I know your quotes are for parts only. You would be better off getting the whole thing, and parting it out yourself.

    Bookmark   March 8, 2009 at 9:35PM
Thank you for reporting this comment. Undo

I have determined mine is the board also. I have a good friend that is a Electricaleng with GE. He came and looked at it. He said no problem fixing the board if he could get a schematic. Can anyone help on this. I have searched the internet and no luck just the instructions on installing the newer board. I have found the p4 control unit for 529.00 if I have to go that route. 3 years ago I bought all of it for 732.00.

can anyone help.

    Bookmark   March 9, 2009 at 8:33PM
Thank you for reporting this comment. Undo

Henry for told his sne Edsel," Go make the cars, et me make the parts."

True story

    Bookmark   March 9, 2009 at 9:38PM
Thank you for reporting this comment. Undo

You may want to google the entire AquaRite. There are many folks out there who like to give, eh "sell" them for under $900.00. I would never pay $700 for a board when you know the other board is not far off and the cell is too.

    Bookmark   March 9, 2009 at 11:21PM
Thank you for reporting this comment. Undo

Mine just started giving me the "no cell power" too. Ridiculous to have to pay this much for a new board after 3 years. Mine went at 3 years, 3 months... Anyone know what goes out on the board, and if it can be fixed? I have the AquaLogic PS8.

Anyone come up with the schematics? How do I know whether it is the board or the cell?

    Bookmark   March 10, 2009 at 11:17PM
Thank you for reporting this comment. Undo

No cell power is either the board or the transformer,or fuse.
29 times out of 30 it is the board. Cell wont give this message.

    Bookmark   March 11, 2009 at 12:11AM
Thank you for reporting this comment. Undo

I had similar symptoms and not much help from Goldline/Hayward other than referring me to my installers. They were good at installing pools probably not repairing electronics. Since I teach electronics I took a crack at it. I found a melted solder joint on the back of K1 (black box on top right of card) I resoldered the connection and it worked like a charm. In my opinion it probably could have been designed better. The fuse and relay are both rated for 20 amps normally if you want to protect something you put a fuse with a lower rating than what you are trying to protect. The relay obviously had become overheated, solder melts around 650-750 degrees depending on the alloy.

    Bookmark   March 11, 2009 at 7:40PM
Thank you for reporting this comment. Undo


    Bookmark   March 11, 2009 at 8:54PM
Thank you for reporting this comment. Undo

Yes, their design has an obvious defect, the through hole is not thermally relieved to the board, and when I called the local pool man he said he has many of these boards back ordered for people with the same problem. At $450 a pop with a warranty Aqua logic is making a killing. I fixed my own board also but only after the pool man told me how much a replacement board was. I think Gold Line Controls should do a recall and pay for my pool man service call. What do you all think? Any body want to force them to do a recall and pay people back that have already pick pocket by Gold Line Controls?

    Bookmark   March 14, 2009 at 3:14PM
Thank you for reporting this comment. Undo

I just got My board off. Same problem the switching leg of the relay had the solder melted. I cleaned it up and resoleded with a silver based solder. If the relay is damaged you can buy them from Mouser electronics less than $4.00. It is dark will install tomorrow and see what happens. Keep your fingers crossed. Maybe we can fix all these boards that everyone is waiting on replacements!! !!

    Bookmark   March 15, 2009 at 9:08PM
Thank you for reporting this comment. Undo

Resoldered the lead on the relay. Installed this morning. All is fixed and well. Thanks for all the help.


    Bookmark   March 16, 2009 at 9:31AM
Thank you for reporting this comment. Undo

Wow. This is great news! I was just about to buy an entire new PS8 just to get the board and replace it myself. That was cheaper than than having someone come out to fix it and me paying 60% "retail" for the board.

Anyone have a picture of the board with the melted connection? I'll take mine off this weekend and see if I can see anything obvious. Hopefully it's the same. Should I use any special solder that will hold up better?

By the way, I'm in for getting Harward to recall these. I have another friend that had the same problem. 3 years, 4 months, and $800 later, they were fixed up with a new board. I talked to a service company yesterday that won't fix these anymore because he said they're happening every 3-4 years and Hayward is bogging them down in paperwork to get their money from them.

I have some electrician background, but not a lot in electronics. Anything I should be careful with when soldering this back together? I.e. not too hot, use a heat sink, specific type of solder, do or don't touch the printed circuit, etc?

    Bookmark   March 20, 2009 at 1:39PM
Thank you for reporting this comment. Undo

I took the main PCB off and immediately saw a burned solder joint on the K1 component. I cleaned it off and resoldered with a silver based solder. Everything is back working like it should.

Navyet, I'm so glad you posted your findings on this. And to everyone else that posted that they fixed theirs the same way. Thank you, Thank you!


    Bookmark   March 20, 2009 at 8:10PM
Thank you for reporting this comment. Undo

I just got my "no cell power" today after 3.5 years to the month. Is the PC board located where the cell plugs in at the control box? Sounds obvious, but I don't want to chase my tail :). I had to replace the cell 90 days ago.
I'll check for power first. Hope there's a reference point on the board. I'll then pull the board and check K1 solder connection. Does it get so hot it melts the solder and a leg and leaves an open circuit?

    Bookmark   April 1, 2009 at 12:08AM
Thank you for reporting this comment. Undo

I just replaced the main board for ps-4. Do you mean I just needed to replace what burnt out on the old board and then it would be good? Also, I am getting solar open circuit, open sensor? Does anybody know about this?

    Bookmark   April 8, 2009 at 10:05AM
Thank you for reporting this comment. Undo

Do you have solar?
If not go into the Config menu, and turn solar off.
If you do have solar, then you need to have a temp sensor ran to the board.
If you have a temp sensor ran to the board, then the wire may be broken, or it is a bad temp sensor.
That should cover most senerios.

    Bookmark   April 8, 2009 at 6:48PM
Thank you for reporting this comment. Undo

Thanks, we found a wire hanging out by the solar panel. Now we have another problem, it says chlorinator off, check system, no flow. Where is the flow switch and is that easy to replace? Please get back with me soon because I have a tech coming out Monday and if my husband could fix it, that would be great!

    Bookmark   April 9, 2009 at 3:48PM
Thank you for reporting this comment. Undo

There is a 2" x 3/4" "T" fitting with a grey wire coming out of it. It has a phone plug on one end, it plugs into the board. Wire could be broken. You can get a new one and screw it in yourself, Under $50.00 I think.

    Bookmark   April 9, 2009 at 11:34PM
Thank you for reporting this comment. Undo

All flow switches are expensive considering what they are. I dont know why. List price part# GLX-FLO-RP is $170.64.

    Bookmark   April 10, 2009 at 10:05AM
Thank you for reporting this comment. Undo

I just wanted to thank everyone for the information. I found this site by searching for "no cell power". I first called Goldline/Hayward, they said to call a pool repair company, I called them and they quoted me a new board price of $650. So I started doing research and stumbled across this site. Low and behold, the K1 connection was fried, so I cleaned it and soldered it and everything works perfect.

I'm thinking of sending an email off to goldline, as this is an obvious defect. I'm sure many more people just replaced their boards without knowing what the problem was. They should be either recalling these or offering free repairs. (See Microsoft and the xbox 360 solder defect)

Thanks again all, just wanted to let you know there are more people out there. Also, I meant to take a picture but was so excited to finally fix it I forgot.

    Bookmark   April 12, 2009 at 2:47PM
Thank you for reporting this comment. Undo

Thanks to you all! I am 3 years 7 months into pool ownership. I was plagued with the same problem... thankfully the fix worked for me also. I hope it lasts!

These faults do seem to be more than a coincidence. The service provider quoted me about $480 with a $70 install. I bet that most of these 'service providers' know about this weakness but, of course, are not inclined to tell anybody - sometimes it is hard to find heroes out there... but I must say you all are mine! :)

Thanks again for the post... saved me more money as a do it yourselfer than ever before.


    Bookmark   April 23, 2009 at 10:05PM
Thank you for reporting this comment. Undo

Don, the list price is $712.80. Maybe they are more of a hero than you think. They have to buy this stuff and keep it in inventory. Trust me, Don, I would rather have money in the bank than a bunch of PCB's on a shelf. If I came to your house and repaired the board and charged you a service call Iwould be gambling that it would work. Because if it failed in 3 weeks you would call me back wanting it fixed again for free, proving that no good deed goes unpunished.

You service provider is trying to earn a living, maybe send his kids to college. So what is it about selling new parts that is such a crime? Why is what you do for a living not a crime?

Keep in mind he is not an electronics engineer nor did he design or manufacture the board.

If you want a hero, buy a comic book.

    Bookmark   April 25, 2009 at 4:59PM
Thank you for reporting this comment. Undo

I need to replace the local display on my AquaLogic. Anyone know where to get one cheaper then $400? The part I need is GLX-local-ps-4

    Bookmark   April 27, 2009 at 10:07AM
Thank you for reporting this comment. Undo

I encountered same problem last weekend - my pool & equipment is only ~2.5 years old. Was going out of town for the week, so e-mailed Hayward tech support from their web-site. They responded by referring me to a local company. When I got back this weekend, I called them and they wanted $99/hr to come out and "diagnose" the issue - expecting min of 2 hrs !!!
Warranty apparently only covers the equipment ... not parts/labour.
I thankfully decided to look online and found this forum.
Verified xformer voltage and fuses - all good, so went ahead and removed the main board. Melted solder connection exactly as described.
E-mailed Hayward again [since weekend] requesting a new board as it is within warranty period - they just responded as follows :
"In order to have the product cover under warranty you will
need to have an authorized service center provide service."
What a disgrace !!!
I took photos of the board and resoldered the connection so I can have my filter running - system is working great - for now. [Thx to all those that make the effort to provide this type of information].
I will be calling Hayward tomorrow - else I guess I will have to involve a lawyer.

Anyone else thinking about a class-action suit ?

    Bookmark   April 27, 2009 at 6:32PM
Thank you for reporting this comment. Undo

Same problems here with my Aqua Logic AQL-P-4!!!
Googled aqua logic & flow switch and I see I'm not alone with this problem!! Just at 3 yrs old and the pool builder is out of buisness!

Getting "check system-check flow switch" & "clorinator off-check flow switch" messages.

*pool temp at 79 degrees
*salt level at 3000 per panel display
*turbo cell is clean as new
*DE filter clean, pumps working just fine

I will check the solder joint at the K-1 location in the morning. * DOES ANYONE HAVE A PICTURE OF THIS LOCATION*?
I have some electronics background so hopefully this is an easy fix rather than the big $$$ for a new board.

Will also re-check fuses and transformer output at the 24v suggested in previous posts.

I have a Q-12DS-C2 flow switch located next to the turbo cell. Does anyone know how to check these? OHM meter reading at the phone jack plug connector???

Thanks in advance for any and all help. I'll let you all know what happens with my process in repair.

    Bookmark   April 27, 2009 at 9:24PM
Thank you for reporting this comment. Undo

You have a different problem, yours is not the board it is the flow switch. It is very simple to change, unscrew it out and bang it around a bit. It just makes or breaks a circuit, you should be able to see the wires entering the clear phone connector if you want to Ohm it out. If it is bad then to get you by for now you can cut the wire and wire nut the two leads coming from the controller together, that way it will think it has flow. Then you can order a new one.
Have fun.
Dont worry your K-1 connection is just around the corner.

    Bookmark   April 27, 2009 at 10:32PM
Thank you for reporting this comment. Undo

Thanks just-a-pb.
Spliced the flow switch wires together this morning and the message on the display immediately went away!

Found switches on line in the $45-$55 range. I'll check at my local pool supply store this morning.

Now I'm showing a low salt level so I'm on my way to get more salt and while I'm there I'll have my water tested. I usually have pretty good luck keeping my water in spec. This is the first salt pool for me of the past 3 I've had and seems to be the easiest to maintain. Just wish that the control board had a better life expectancy. At least I'm prepped for the K1 connection problems thanks to you all.

    Bookmark   April 28, 2009 at 10:22AM
Thank you for reporting this comment. Undo

Have your salt level checked by the pool store or test it yourself with test strips. The salt level reported by the controller is not always accurate due to the way it is calculated and you may be getting an inadvertent low reading.

    Bookmark   April 28, 2009 at 5:58PM
Thank you for reporting this comment. Undo

Thanks bignick.

That brings up another small problem that I have with this system. The salt level reading on the controller always reads lower that when I test it using strips or take the water sample in to my local pool store for testing.

The problem being is the chlorinator will not produce if the controller reads a "low " salt reading but the pool actually has adequate salt levels.

Is there any way that the readings can be adjusted inside the controller to reflect a more accurate PPM???

    Bookmark   April 29, 2009 at 8:03AM
Thank you for reporting this comment. Undo

Is the cell perfectly clean? If not it will not give proper reading.
Also you can go into the diagnostics menu, once the cell powers up, check the salt reading, then hit the up arrow, and check that reading. This checks both sides of the cell + and -. They should be the same number, if not cell may be failing.
Strips and liquid salt level testers are not that accurate IMHO, you need an electronic tester to get the most accurate number.

    Bookmark   April 30, 2009 at 1:35AM
Thank you for reporting this comment. Undo

Also, the temp of the water will effect the reading. Cold water almost always produces a lower reading. If the temp is above 60-65 degrees then the cell needs to be calibrated. See the manual for the how to for your unit.


    Bookmark   April 30, 2009 at 4:30AM
Thank you for reporting this comment. Undo

Good information.

I have a little different issue but may be related to the same cause. My pool water was at a salt level reading of 3000 ppms and immediately dropped to zero. I have cleaned the cell with a 4:1 water/acid bath and still no reading.

Any suggestions?

    Bookmark   April 30, 2009 at 11:43AM
Thank you for reporting this comment. Undo

Help!!! Anyone have any insight to cell power error without burnt out solder joint? I have local pool company that tested and said they only show -24v and the board needs replacing. Thankfully the board is under warranty...but the labor to replace is not. They want like $150 for replacement and i want to do it myself. Money is tight nowadays..they told me I will void my warranty if I do it myself... HELP!!!!

    Bookmark   May 8, 2009 at 2:42PM
Thank you for reporting this comment. Undo

See, I'm in the same boat. My board doesn't have any visible defect and Hayward is telling me the error message indicates a bad board. On the Goldline site, they "recommend" professional installation, but they don't specifically prohibit a self install (see link). I'm trying to find out if I can handle the warranty work without going through a dealer. Heck, I was able to diagnose a prior problem with the heater relay after the local tech came out and just stared at it.

Here is a link that might be useful: AquaLogic FAQ

    Bookmark   May 8, 2009 at 3:34PM
Thank you for reporting this comment. Undo
pc77375 I recommend that they pay for the labor to replace it, they don't agree with my I should be able to install myself. I am sure it is not that difficult, I have seen way more complicated things!

Here is a link that might be useful:

    Bookmark   May 8, 2009 at 4:12PM
Thank you for reporting this comment. Undo

Board is not hard to replace, if you are careful not to tear off one of the tabs for the 20 wires connected to it.
If you do tear one off then there goes the warranty.
Hayward would problably let you do it, but they will want you to ship your board to them first, and then they will send you a replacement. So it wont function for how ever long that all takes.
Help out the recession and pay to have it done. This doesnt mean you cant bargain a little. It takes all of 5 minutes to change the board. Maybe another 3 to reprogram.

    Bookmark   May 8, 2009 at 8:09PM
Thank you for reporting this comment. Undo

See my earlier post - direct quote from Hayward when asked if I could remove the board myself and take it in for replacement :

"You will need to have the service center go out to the unit
for service. You can contact them and see if they have PCB boards in stock.

Hayward Technical Services
One Hayward Industrial Drive
Clemmons, NC (USA) 27012

This is disgraceful as the board has a known issue and is under warranty still. (I checked and confirmed same solder joint problem - very obvious).
How can they force us to pay for a service call when their hardware under warranty is bad ???
Should be able to get a replacement shipped from Hayward direct or physically swapped for a new one at the company they said handles their warranty issues locally.

Also, is there a newer revision for these boards that is not suseptible to this fault ?

Has anyone that has repaired the solder joint seen it re-occur ?

    Bookmark   May 8, 2009 at 9:55PM
Thank you for reporting this comment. Undo

Sahertz...I am right there with ya!! My sister is an attorney, and we are having some interesting discussions about this deal.

Anyway. I've had the same "no cell power" issue with my Aqualogic. I did the fix on the "nocellpower" site offered in darentx's message above...and it worked like a charm - as I definitely DID have the burned out joint. It saved me over $800. And for a single mom of two, or ANYONE for that matter, that is a lot of money! Especially for something that seems to be a known issue.

It makes you wonder how many "non reputable" service companies just fix your existing panel and still charge you for the new one. How would you ever know, unless you asked for the old panel back? The whole thing made me sick as I stressed over this for MONTHS! Not to mention spent more time on maintenance, and spent additional money on chlorine pucks, shock, etc., to chlorinate my pool as I just didn't have the money to fix the panel right when the error came up.

I'm so thankful that this "fix" was posted as it was truly a blessing to me and my family this summer! (And...I'm more than willing to call on a service company to come make a "needed" repair to my pool, because it's worn out or reasonably "broken"...but this one was a bit unreasonable for a consumer to swallow.)

I'm going to continue to follow this posting as it's troubling that hardworking consumers are being asked to pay for a repair that seems like it should be a "recall" due to faulty manufacturing.

( "mikethepoolguy", your comment back to Don was just so rude! Most people nowadays are just looking to do things economically "smart", and working hard to do so. Obviously, most consumers aren't pool experts, and certainly not pool systems engineers - and when appropriate, pool owners are more than ready to pay for good maintenance and honest repairs. We wouldn't have pools if we weren't! But a little bit of help goes a long way. Karma, mikethepoolguy, Karma.)

    Bookmark   May 22, 2009 at 5:00PM
Thank you for reporting this comment. Undo

Thanks to Navyet. Your repair worked for me also, saving me hundreds.

For the public record - My pools been operating for 19 months, power to cell failed at 16 months.

As an engineer, I recognize this design defect could be easily fixed during original manufacturing. My guess is they are making to much money to care.

If class action is what it takes, let's get the ball rolling.

    Bookmark   June 7, 2009 at 2:49PM
Thank you for reporting this comment. Undo

My system shows no voltage or amps on the diagnostic window, and the salt level is 0000. When I reset the chlorinator, it counts down to zero and then clicks on for a split second (I hear the voltage noise), the display shows voltage for a split second and then goes back down to zero. Any ideas? Goldline, of course, said "replace the board". $500.

    Bookmark   June 9, 2009 at 12:07AM
Thank you for reporting this comment. Undo

Okay, well though it was not exactly the same symptoms as some of the above, I pulled off the main board and looked at the bag. Indeed the one connector (as depicted here: was burned a bit. I carefully turned on the power and pushed a grounded screwdriver into the burned area and waited for the chlorinator to come on, and presto, it did and the amps & volts were fine. When I'd remove the screwdriver (thereby breaking the connection) the volts & amps dropped to zero.

So I powered it off again, fetched my handy soldering iron (Sears Craftsman purchased in 1983 for some high school projects) and added solder to the connection.

And now, it's fixed - at least for now. Looks like this is too common of a problem for goldmine not to recall the boards and reinforce this connection.

My thanks to the folks above who provided some guidance -

Eeep eep says the monkey!

    Bookmark   June 9, 2009 at 8:22PM
Thank you for reporting this comment. Undo

Thanks to you all! I had my salt cell tested and it failed, bought a new cell and still had "no cell power" message. Was about to give up and call pool company, and stumbled across this forum. Re-solder bad connection and I am back in businessÂ..

I do have a question; why is this connection burning out? Is there another problem with my system that is causing excessive heat and/or power going through this connection?

Also, I have been down with out the salt generator for about 3 weeks and have been tablets to keep up the chlorine level, now I have mustard algae! Will this disappear after awhile since my system is back to normal, or do I need to add something??

    Bookmark   June 10, 2009 at 4:40PM
Thank you for reporting this comment. Undo

Had a new mother port put in Jan. 09 under warranty. Burnt post- paid labor. Had solar installed two weeks ago, now no cell power shows up again; post not burned fuses are good. Guess I have to play the warranty game until my warranty is up. I understand p4's are garbage. Any solutions to my problem; I agree a class action should be filed, where do I sign up? Is there a better salt system that I can purchase to go with my p4?

    Bookmark   June 14, 2009 at 10:35AM
Thank you for reporting this comment. Undo

What really bothers me is that I am replacing PCBs (warranty and otherwise) without knowing if the problem has been fixed on the new board.

Other suggestions: Purchase a Aquarite (control only). Your cell will work with it.

Purchase a complete chlorine generator, any brand, as the K1 problem does not affect other parts of the programming. You will not be able to control the system with the Aqualogic, but you will have a CG that works.

    Bookmark   June 14, 2009 at 2:20PM
Thank you for reporting this comment. Undo

I've got the same problem as Karl_pool. Apparently I have a bad flow switch. Can anyone suggest a site where I can purchase one at a reasonable price? Thanks.

    Bookmark   June 20, 2009 at 4:07PM
Thank you for reporting this comment. Undo

I received the dreaded "no cell power" message after about 44 months of operation. Goldline replaced the board after I fussed about it and once installed it shows no readings for salt/chlorination, or all the timer options I need. How can this be programmed??!?!?! Thank you.

    Bookmark   June 26, 2009 at 10:27AM
Thank you for reporting this comment. Undo

Programming instructions are in the manual. If you don't have one, you can download it from the Goldline web site. In the configuration menu, you'll need to enable the solar option. There may also be an option to tell it which salt cell you are using; make sure this setting is correct. Kinda lame that the installer didn't make a note of your settings and copy them to the new board.

Here is a link that might be useful: Goldline Controls Manuals

    Bookmark   June 26, 2009 at 5:24PM
Thank you for reporting this comment. Undo

I also got the no cell power message and the board was replaced. Now... I am getting that the chlorinator is off because of very low salt. However my salt level is 3100. The diagnostic menu and the default menu both now say that I have 0000 ppm. Can I override the chlorinator off command? How do I get it to read the correct salt amount?

    Bookmark   July 2, 2009 at 10:35PM
Thank you for reporting this comment. Undo

I was checking out a chlorination problem on my AQL-4 and I took the trouble of tracing the circuit that provides power to the Cell system. If you want a copy of the hand drawn diagram send me an e-mail request.

    Bookmark   July 11, 2009 at 1:55PM
Thank you for reporting this comment. Undo

this message is to escalante1,,, how do i request the hand drawing of the circiut that powers the cell? I do not have the burnt pin at K1. I would love to trace this circuit and try to make a repair myself, surely this cant be that hard, all the componets should be availible somewhere other than Hayward for $700?? Thanks for the help

    Bookmark   July 17, 2009 at 3:18PM
Thank you for reporting this comment. Undo

WOW...thanks so much for this page and instructions! You saved me over $850 this past weekend and the system is up and running fantastic!.. it was an easy 20 minute job!....


    Bookmark   July 27, 2009 at 10:36AM
Thank you for reporting this comment. Undo

Can anyone help out with a wiring diagram of the OLD PS-4 mainboard? My old board has the same "K-1 burn-through" that you have all had, and I replaced it with a new one that is wired slightly different. Now, it has failed also (not the K-1) and I repaired my old board but can't reinstall it due to the different wiring. My old board that I want to re-install has only ONE orange wire and the new has TWO. So, if you have the OLD board with one orange, can you help me out? I just need to know what wires go to which rectifiers. Thank you!

    Bookmark   August 23, 2009 at 3:52PM
Thank you for reporting this comment. Undo

Yep. Same exact problem here. Looking for someone to fix the fried joint for me. I can't solder at all. I'm certainly down for a class-action suit against the company. They clearly could care less - until they're hit with a lawsuit of course.

    Bookmark   April 13, 2010 at 2:12PM
Thank you for reporting this comment. Undo

Resoldered the fried joint myself. There's a post above with a link that i used. All systems seem to be working now. Thanks to you guys who shared this info, saved us hundreds.

    Bookmark   April 14, 2010 at 11:03AM
Thank you for reporting this comment. Undo

Hi all -

My system is 5 years 4 months and I have had the "no cell power" message since April. I attempted to fix the K1 joint this weekend, and while the connection did not have a "burn" mark it definitely looked a bit skimpy. I added solder and started it up, and lo and behold! the "no cell power" light went off!! so yay!


Now the doo-hickey (capacitor, maybe?) with all the wires located next to the K1 element (sorry for the ridiculous description - I am defintely an electronics neophyte!)has a significant vibration and is heating up quite a bit - to the point where it will periodically cut off to cool down. When it cuts off, or stops vibrating, all power to the cell cuts off too. Additionally, since the "repair", the pool lights do not work.

I have checked the fuses and all seem OK, and I have removed and reseated all switches and connections, but still have the same problem.

Any ideas on where to proceed next? My pool builder is happy to replace for $750, but before I go there just want to make sure I have explored all options.

Thank you in advance - I look forward to any recommendations!

    Bookmark   June 1, 2010 at 2:12PM
Thank you for reporting this comment. Undo

Hi. Can anyone help me ? My salt reading on aqualogic ps4 with 5 month old new motherboard is not reading correctly.
Cell is clean btw. The - and + are not the same. The + reads 200 and the - reads 3200 but according to testing the salt is way too high 4000!! Question is this the cell I need to replace or is the motherboard broken again? Thanks for the answer;)

    Bookmark   February 9, 2011 at 8:11PM
Thank you for reporting this comment. Undo

First try unplugging it and plugging it back in. Sometimes it doesnt seat well.
With huge differences in - and + readings it is usually the cell that is bad.
Generally the cells last from 3 to 5 years, depending on how well they were taken care of.

    Bookmark   February 9, 2011 at 10:07PM
Thank you for reporting this comment. Undo

What is your water temp? As the water temp drops, it's conductivity also decreases. This is what cells use to check the salinity.

Typically, a 5 degree drop from 75 will show a 200 ppm decrease continues that trend with each 5 degree drop, at least with Pentair cells. I can't see the Hayward's being all that much different unless they have temperature compensation like an Auto-Pilot. Even still, they still shut down in cold water, typically around 60 degrees F.

Are there any errors being reported? What are the voltage and current levels being reported in the Diag menu? Are you reading the instantaneous levels?

After following just-a-pb's suggestion, if the issue isn't resolved, Power down the PS-4 for a couple minutes and power it back up. Check the clock, then check the Diag menu in 15 minutes.

Test for FC. if it's low, use Clorox to get it where it belongs. The pool calculator will tell you how much. That will get you by until this is resolved.


Here is a link that might be useful: The Poool Calculator

    Bookmark   February 10, 2011 at 5:36AM
Thank you for reporting this comment. Undo

Having same problem, and my blower is dead also. What are relays K2 and K3 for? Figure I'll fix them all at once!

    Bookmark   May 7, 2011 at 11:47AM
Thank you for reporting this comment. Undo

My aqualogic had the same 'no cell power' message (1 year after warranty is up of course). Thank god I found this message board before calling my local pool company at $100/hr, who usually have no idea what they are doing when it comes to the aqualogic anyways.

Thanks to previous posts I knew to disconnect and check the back of the circuit board, it was the K1 circuit just as everyone had said. I called a couple of pool and electric companies, and they had no idea how to clean and/or resolder it. So I called a computer repair company and asked if they would take a look at, 1 hour and $10 later the circuit board works again!

Thank-you everyone who took the time to post this information online, you probably saved me close to $1000 and I am very appreciative. I hope others find these posts useful.

    Bookmark   June 8, 2011 at 9:26PM
Thank you for reporting this comment. Undo

I am bumping this thread to keep it on everybody's mind. I am a longtime member of GW and built my pool with you folks, I think it is still getting viewed in the gallery. It is now 4 1/2 years old and we still enjoy it immensely. Recently we got the "no cell power 2" error message and like everybody else, we were told we would need to replace the board at a cost of about $750 (parts) plus labor. I started googling and found nocellpower dot com where there were lovely, easy to follow instructions on how to fix this problem. The website even acknowledges my favorite forum, gardenweb and even mentions navyet!! So thanks to navyet and darentx also, THIS WORKS!! It took me 2 tries at soldering, I think I used bad solder the first time but it works! I think I spent about $30 on supplies and that is because I bought a soldering iron, if you can borrow one your cost would be practically nothing. Hopefully this fix lasts, I have faith in it. So all you new pool owners, keep this thread in the back of your mind if you go with the aqua logic. Obviously, it has a design flaw if over 300 people have commented on that website, just think how many people use their info and don't comment!

Here is a link that might be useful: the very helpful instructions

    Bookmark   June 27, 2011 at 9:13AM
Thank you for reporting this comment. Undo

looking at the PS4 system. would most of you folks out there still purchase this system if you had to do it over again? Thanks steve

    Bookmark   July 6, 2011 at 1:06AM
Thank you for reporting this comment. Undo

Reviving this thread is so timely! We have repaired our board now
3 times, and it has failed again. We replaced the K1 relay as well. Our system is 4 years old, so we must be nearing the end of our cell life, tho it has always been clean. We have an Aqualogic PS8.
It looks like the new replacement cell requires a new board anyway, and the new board, if we got the Pro vs the Main, requires a new display. Sheesh.
So we want advice. We are thinking of tossing the whole dang thing, and replacing it with an Intellichlor. Or we could do just the Intellichlor cell and power supply, and keep using the PS8 to control the waterfall, Hayward LED lights, etc.
Which leads to another ?. Will the Pentair be able to control Hayward lights smoothly?
We will never buy another Hayward/ Goldline product. To have a $1500. system fail after 3 years is disgraceful.
Last question, are there any known issues with Intelichlor like the Aqualogic one?
Any advice is appreciated. Seems the minimal fix is 1,000 dollars.

    Bookmark   July 6, 2011 at 8:54AM
Thank you for reporting this comment. Undo

Pentair EasyTouch with a cell and remotes as needed or a Jandy/Zodiac RS-8, cell, and remotes as needed.


    Bookmark   July 6, 2011 at 9:38PM
Thank you for reporting this comment. Undo

Thank you for your reply. I think the easyTouch will work. I decided against the "Gee whiz" Intellitouch due to expense. I would like to use the IC 60 since I have a 32k gallon pool. I only have a pool ( no spa), so I have a pool pump, waterfall pump, booster pump, Colorlogic lights. It seems that the IC60 only comes bundled with the EasyTouch 8sc ( part number 521150). It's $2k. There must be a cheaper way to do this with the IC60. My pool builder went out of business, so I am orphaned here.
Thanks for any advice!

    Bookmark   July 7, 2011 at 12:04PM
Thank you for reporting this comment. Undo

Ok, I think I've got it. I talked to Azwholesales, and he said he could bundle an IC 60 w a 4p, and charge me the difference in the cells. I'm looking at $1162. before shipping.

He also said Pentair is coming out with IPhone capability
for the EasyTouch in Aug/Sept time frame.
It will just need the interface added to the existing stuff. Sweet!

Thank you for your help!!

    Bookmark   July 7, 2011 at 2:06PM
Thank you for reporting this comment. Undo

I have fixed my K1 relay a number of times using the information from here. Now my unit is showing a voltage of 40V. That is too high I am told. Any one has this issue? I think mine was damaged during the last thunderstorms in our area. Any easy and cheap fix that anyone know of? Please help. Thanks.

    Bookmark   November 1, 2011 at 1:36AM
Thank you for reporting this comment. Undo

Hi started my pool today and i get check system (check system pool brake conn)???any idears,Thanks

    Bookmark   May 15, 2012 at 10:19PM
Thank you for reporting this comment. Undo

Hi Everyone,

I am having the same issue regarding the "No Cell Power"....

This is my Aqua Logic Goldline box:

I easily removed the cover:

And when I removed the control box, as per the vedio above, the back of the circuit board looked clean without any burned out ends.............

Are there any other suggestions for me? Thanks in advance to anyone who comments.


    Bookmark   June 9, 2012 at 1:25PM
Thank you for reporting this comment. Undo

my check system came on my NEW, 4 month old logic system...all I can figure out from the diagnostics menu is it MIGHT be the flow switch...not really sure.

    Bookmark   August 24, 2012 at 10:17PM
Thank you for reporting this comment. Undo

I was getting an alarm on my display - Chlorinator off -with no salt reading showing. After checking my cell, I realised the problem was in the PCB. FOund the solution provided earlier about the solder on K1 and sure enough after resoldering, the chlorinator came back on and the salt reading started to show (3100 ppm). however, my display continues to show 'Low volts' with the yellow alarm light, despite what I think is correct reading for approx 3000 ppm chloride. Any advice on how to reset the alarm?

    Bookmark   February 4, 2013 at 10:52AM
Thank you for reporting this comment. Undo

I've ordered my digi-key parts and paid for 2-3 day shipping. In the meantime if anyone has any suggestions on the preferred soldering material I'd appreciate any replies. New to forum, not electronics, aside from the aqualogic DIY ps-4 fix. I'm open to suggestions too! Thanks in advance. SGT of Marines 91 - 99. Fixer of my own pool hardware.....or at least about to be I hope!

    Bookmark   March 20, 2013 at 2:54PM
Thank you for reporting this comment. Undo

My Goldline Aqualogic system is over eight years old. When I got the "no cell power" on the display, I just figured that it was time to replace the cell or maybe replace the entire system with a new one. I'm glad I searched on the problem, because I just finished re soldering the connection and the problem is gone! Maybe I will get another eight years out of it. Thanks for the sharing this fix.

    Bookmark   October 16, 2013 at 11:25PM
Sign Up to comment
More Discussions
Obsessing over pool finishes
Hello all, I am looking for any and all advice on pool...
J.L. Blodgett abandons pool project
I wanted to send along a note of caution to all members...
Please evaluate my quote for new pool build
I recently received the following quote for a vinyl...
New Pool Build in Cypress near Houston
Well, the Big Dig did not begin Monday. Our PB stopped...
New Pool in Louisiana
Wanted to share a few pictures of our new pool. It...
Sponsored Products
Westinghouse Lamp Shades 10 in. Handblown Clear Chimney with 3 in. Fitter and
$5.97 | Home Depot
Derby Woven Leather Rug 8' x 11' - CHESTNUT
$4,129.00 | Horchow
Area Rug: Contempo Light Multi 7' 8" Round
Home Depot
Windster 48W in. RA-77 Series Wall Mounted Range Hood - RA-7748
$950.00 | Hayneedle
Tiffany Style Pansy florall Glass Shade Ceiling Pendant Light
Casdon Kids Play Little Henry Vacuum - 580
$31.75 | Hayneedle
Modern Block Rug 5' x 8' - SLVRGRY ON LTGRY
$699.00 | Horchow
Woolrich Plaid Shadow Rectangular: 5 Ft. 3 In. x 7 Ft. 10 In. Rug
$170.40 | Bellacor
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™