Washing machine odor

criticalmass048October 18, 2010

After running our washing machine, there's an odor. Sort of like a sewer backup. This is pretty recent, like in the past few weeks. Any ideas? Thanks in advance.

Thank you for reporting this comment. Undo
brickeyee

Check the lint filter if the machine has one.

Some are in the middle of the agitator.

    Bookmark   October 18, 2010 at 9:51AM
Thank you for reporting this comment. Undo
randy427

Front-loaders are known to have mold issues since the door seals tightly, preventing the residual water from evaporating.

    Bookmark   October 18, 2010 at 10:12AM
Thank you for reporting this comment. Undo
criticalmass048

This is an old top-load. We've had it for 10+ years and never had a problem. I'll look and see if there's a lint filter (guilty look)

    Bookmark   October 18, 2010 at 10:28AM
Thank you for reporting this comment. Undo
brickeyee

"This is an old top-load. We've had it for 10+ years and never had a problem. I'll look and see if there's a lint filter (guilty look)"

Often under the softener dispenser in the agitator.

    Bookmark   October 18, 2010 at 2:42PM
Sign Up to comment
More Discussions
toilet flapper closes too fast
a 5 y.o. AS 4396 w/Fluidmaster guts. The flapper is...
fritzgarden
New under mount sink - drain off-center?
I had a new granite countertop installed with an under...
mike_lee2
shower problem....can someone give me a clue?
My hot water plumbing JUST started acting "wonky."...
bevangel_i_h8_h0uzz
Can we bypass old hot water heater?
Any reason we can't bypass and then remove this old...
shellking
Garden Hose iced over
Ok, I know I was stupid. I'm new to home ownership...
Cassandra
© 2015 Houzz Inc. Houzz® The new way to design your home™