Camera repair

sharon620September 4, 2007

Hello Everyone,

I have a new Canon Rebel XTi. I cannot get a card into the slot. All of a sudden this happened. And when I look thru the view finder ( OH MY G) is looks like there is little scratches all over. I used my air cleaner and it got some of it off. But what a mess! I cannot figure out what happened to it.

Does anyone have any suggestions as to what I can do myself?

Otherwise I will have to take it to be repaired. And NO card will go in there. I have tried other cards and they won't go in either.

Thank you

Sharon

Thank you for reporting this comment. Undo
zitro_joe

Sharon, did one of the pins get bent?

As far as the view finder, maybe dust? but the XTi has a "dust buster" maybe it is just on the view screen and not the sensor. Take to the camera shop, they shouldn't charge to have a glance at it. Is your camera still under warranty? Should be an easy fix then.

Zjoe

    Bookmark   September 4, 2007 at 1:01PM
Thank you for reporting this comment. Undo
zitro_joe

Sharon,
I received your email. The best advice I can give is contact Canon directly. Most likely, you have to send it in. Be sure to to ask about a 'loan' camera to have while they look at yours. I don't know if I could make it through the day without a camera.

Check here, too:
http://forums.dpreview.com/forums/forum.asp?forum=1031

Lots of people smarter than me there.

Hope I was some help

Zjoe

    Bookmark   September 4, 2007 at 5:52PM
Sign Up to comment
More Discussions
Homemade PVC Photo Booth
I normally post in another Garden Forum, but thought...
oldalgebra
The 73 most expensive photographs ever sold
Here's a cool article listing (and showing) The 73...
JamesScott86
Mid-range DSLR Recommendations?
I've been kicking around the idea of finally ditching...
Swentastic
kentuck_8b
A question
I guess this is a somewhat different subject but it...
gmom74
© 2015 Houzz Inc. Houzz® The new way to design your home™