Asko w6884eco washer problems

conateApril 5, 2012

My wife and I bought one of these machines end of December and installed it early January.

We have had a huge number of bizarre problems: cycles stopping in the middle, the machine pumping continuously when o water present, and other things.

The circuit board has been replaced once and it is going to get replaced again.

Has anyone else had these problems with this machine?

Thanks ! Nathan

Thank you for reporting this comment. Undo
Sandy16

Do you have a copy of your service manual? If not, get one. Is your repair person knowledgeable about Askos or has replacing the board been used as a fix? Has the drain pump been removed and checked? I'm wondering if the washer is draining enough to drain the tub but not the pump.

    Bookmark   April 6, 2012 at 10:42AM
Thank you for reporting this comment. Undo
conate

Thank! We've just had a third board put in, so that's obviously not fixing it. The drain pump seems likely.

The other bizarre things...like a cycle just stopping...not sure about that one.

    Bookmark   April 10, 2012 at 10:49PM
Sign Up to comment
More Discussions
Magtag TL leaving white film on clothes
My Maytag has a selfcleaning filter, and I've had it...
sweeterthanhoney
Need help with LR/Mudroom/PR arrangement
We are breaking ground in 3-4 weeks and we still haven't...
daboyd4
Do HE TL washer really Clean?
I have had a traditional Maytag TL washer for the last...
jungleexplorer
Kenmore Elite Front Load Washer Smell
We have a two year old Kenmore Elite Front Load Washer...
joechsle
don't buy a samsung washer or dryer
I am in the market for a new set so I called my trusty...
monaw
© 2015 Houzz Inc. Houzz® The new way to design your home™